summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2019-07-12 07:29:18 +0100
committerWill Handley2019-07-12 07:29:18 +0100
commit2ab65121646ac481d9279513b9d8a97b4e954700 (patch)
tree652032925e26d8b7e34a5c6f3013dc1ca13313a9
parent9562f30010b2b14b0d0ed3faa45ea7cbe6dcbb6b (diff)
downloadaur-2ab65121646ac481d9279513b9d8a97b4e954700.tar.gz
Added tests
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b35fa0bff0c8..9ff48b90fc38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Jan 21 17:43:42 UTC 2019
pkgbase = python-getdist
pkgdesc = MCMC sample analysis, kernel densities, plotting, and GUI
pkgver = 0.3.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cmbant/getdist
arch = any
makedepends = python-setuptools
diff --git a/PKGBUILD b/PKGBUILD
index 3ec8a246a6c0..51df1e244838 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_modulename=getdist
pkgname=python-$_modulename
pkgver=0.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="MCMC sample analysis, kernel densities, plotting, and GUI"
arch=(any)
url="https://github.com/cmbant/getdist"
@@ -24,3 +24,7 @@ package() {
python setup.py install --root="$pkgdir/" --optimize=1
mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
}
+check() {
+ cd "$srcdir/$_modulename-${pkgver}"
+ python setup.py test
+}