summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2017-09-11 18:21:54 +0100
committerWill Handley2017-09-11 18:21:54 +0100
commit3fa114ae7138be9c214bf8d0779fd928254e2f57 (patch)
treed09caba973f3dce4256590db74121b4cac7ff8cc
downloadaur-3fa114ae7138be9c214bf8d0779fd928254e2f57.tar.gz
First commit of Getdist 0.2.7
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05eea48a7295
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-getdist
+ pkgdesc = Python cosmology library for plotting Bayesian Posteriors.
+ pkgver = 0.2.7
+ pkgrel = 1
+ url = https://github.com/cmbant/getdist
+ arch = any
+ makedepends = python-setuptools
+ depends = python-numpy
+ depends = python-matplotlib
+ depends = python-six
+ depends = python-scipy
+ depends = python-pyside
+ depends = python-pandas
+ options = !emptydirs
+ source = https://github.com/cmbant/getdist/archive/master.tar.gz
+ sha256sums = 7c103e8efa34959b01286b568913a839c5c1fe3c61d6c0b36bfcca2a2a8ed83a
+
+pkgname = python-getdist
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0aefe0dd7d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk>
+_modulename=getdist
+pkgname=python-$_modulename
+pkgver=0.2.7
+pkgrel=1
+pkgdesc="Python cosmology library for plotting Bayesian Posteriors."
+arch=(any)
+url="https://github.com/cmbant/getdist"
+license=()
+groups=()
+depends=('python-numpy' 'python-matplotlib' 'python-six' 'python-scipy' 'python-pyside' 'python-pandas')
+makedepends=('python-setuptools')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=('https://github.com/cmbant/getdist/archive/master.tar.gz')
+sha256sums=('7c103e8efa34959b01286b568913a839c5c1fe3c61d6c0b36bfcca2a2a8ed83a')
+
+package() {
+ cd "$srcdir/$_modulename-master"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+}