summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2021-06-05 07:40:49 +0100
committerWill Handley2021-06-05 07:40:49 +0100
commite94b773e7658e4439c74a0e8dd59ee830f35fb44 (patch)
tree037db7a8507fd32e31eb0ed0e0c486c65048626f
parent105267e69b2f200d32071981561aed49eae6f26d (diff)
downloadaur-e94b773e7658e4439c74a0e8dd59ee830f35fb44.tar.gz
1.3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 980c0ad1a8b3..c617552d8bd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-getdist
pkgdesc = MCMC sample analysis, kernel densities, plotting, and GUI
- pkgver = 1.2.1
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/cmbant/getdist
arch = any
@@ -12,8 +12,7 @@ pkgbase = python-getdist
depends = python-pyside2
depends = python-pandas
options = !emptydirs
- source = https://github.com/cmbant/getdist/archive/1.2.1.tar.gz
- sha256sums = 1b532477741ec4dec042b8977cbe1ab327e1e22e4cb5dfe37dfdb89b61d3d9f5
+ source = https://github.com/cmbant/getdist/archive/1.3.0.tar.gz
+ sha256sums = 8828031446fc91c0725f970c11bc79ad3442f8ea0360daebadd60ceaaed79a60
pkgname = python-getdist
-
diff --git a/PKGBUILD b/PKGBUILD
index bb744e6a5e7e..0fe4833d4f00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
_modulename=getdist
pkgname=python-$_modulename
-pkgver=1.2.1
+pkgver=1.3.0
pkgrel=1
pkgdesc="MCMC sample analysis, kernel densities, plotting, and GUI"
arch=(any)
@@ -17,14 +17,12 @@ backup=()
options=(!emptydirs)
install=
source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=('1b532477741ec4dec042b8977cbe1ab327e1e22e4cb5dfe37dfdb89b61d3d9f5')
-
+sha256sums=('8828031446fc91c0725f970c11bc79ad3442f8ea0360daebadd60ceaaed79a60')
+build() {
+ cd "$srcdir/$_modulename-$pkgver/"
+ python setup.py build
+}
package() {
- cd "$srcdir/$_modulename-${pkgver}"
- python setup.py install --root="$pkgdir/" --optimize=1
- mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ cd "$srcdir/$_modulename-$pkgver/"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
-#check() {
-# cd "$srcdir/$_modulename-${pkgver}"
-# python setup.py test
-#}