summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-01-20 15:19:37 -0800
committerclintval2018-01-20 15:19:37 -0800
commit66e5c4a0c02c12de1ad6a9934a800c4a175bae51 (patch)
tree8063ef927780eac85cd2a3132a5ba8a30e3516ee
parent07f8cb6b6d09483862ec78f5435098377d63d502 (diff)
downloadaur-66e5c4a0c02c12de1ad6a9934a800c4a175bae51.tar.gz
python-gffutils to split package
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD83
2 files changed, 85 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4804f62166d2..743a39294ae1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,37 @@
pkgbase = python-gffutils
- pkgdesc = GFF and GTF file manipulation and interconversion
+ pkgdesc = GFF and GTF file manipulation and interconversion in Python
pkgver = 0.9
- pkgrel = 1
- url = https://github.com/daler/gffutils
+ pkgrel = 2
+ url = https://pypi.python.org/pypi/gffutils
arch = any
license = MIT
+ makedepends = python
makedepends = python-setuptools
+ makedepends = python2
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = python-gffutils-0.9.tar.gz::https://pypi.python.org/packages/b4/ea/54ca403a8d471849606fb432b9afcf73c8c5105ea2dd87b8d38bd5217c5a/gffutils-0.9.tar.gz
+ sha256sums = e1b0bf2b422ec3491be13d77bf7baf71d274abd844e8f8b6c1217a95b236218b
+
+pkgname = python-gffutils
depends = python
depends = python-argcomplete
depends = python-argh
depends = python-pyfaidx
depends = python-simplejson
depends = python-six
- optdepends = python-biopython: for sequence manipulation
optdepends = bedtools: for genomic interval arithemtic
+ optdepends = python-biopython: for sequence manipulation
optdepends = python-pybedtools: wrapper for bedtools
- source = https://github.com/daler/gffutils/archive/v0.9.tar.gz
- md5sums = 819e44d2995175d6b0e575ecf07fc50f
-pkgname = python-gffutils
+pkgname = python2-gffutils
+ depends = python2
+ depends = python2-argcomplete
+ depends = python2-argh
+ depends = python2-pyfaidx
+ depends = python2-simplejson
+ depends = python2-six
+ optdepends = bedtools: for genomic interval arithemtic
+ optdepends = python2-biopython: for sequence manipulation
+ optdepends = python2-pybedtools: wrapper for bedtools
diff --git a/PKGBUILD b/PKGBUILD
index 40dff97c79e5..27cf49606e67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,72 @@
# Maintainer: Clint Valentine <valentine.clint@gmail.com>
-pkgname='python-gffutils'
+_name=gffutils
+pkgbase='python-gffutils'
+pkgname=('python-gffutils' 'python2-gffutils')
pkgver=0.9
-pkgrel=1
-pkgdesc="GFF and GTF file manipulation and interconversion"
+pkgrel=2
+pkgdesc="GFF and GTF file manipulation and interconversion in Python"
arch=('any')
-url="https://github.com/daler/gffutils"
+url="https://pypi.python.org/pypi/gffutils"
license=('MIT')
-depends=(
- 'python'
- 'python-argcomplete'
- 'python-argh'
- 'python-pyfaidx'
- 'python-simplejson'
- 'python-six')
-optdepends=(
- 'python-biopython: for sequence manipulation'
- 'bedtools: for genomic interval arithemtic'
- 'python-pybedtools: wrapper for bedtools')
-makedepends=('python-setuptools')
-ptions=(!emptydirs)
-source=("https://github.com/daler/gffutils/archive/v${pkgver}.tar.gz")
-md5sums=('819e44d2995175d6b0e575ecf07fc50f')
+makedepends=(
+ 'python' 'python-setuptools'
+ 'python2' 'python2-setuptools')
+options=(!emptydirs)
+source=("${pkgname}"-"${pkgver}".tar.gz::https://pypi.python.org/packages/b4/ea/54ca403a8d471849606fb432b9afcf73c8c5105ea2dd87b8d38bd5217c5a/gffutils-0.9.tar.gz)
+sha256sums=('e1b0bf2b422ec3491be13d77bf7baf71d274abd844e8f8b6c1217a95b236218b')
+
+prepare() {
+ cp -a "${_name}"-"${pkgver}"{,-py2}
+}
package() {
- cd "${srcdir}/gffutils-${pkgver}"
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
}
+
+build(){
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
+ python2 setup.py build
+}
+
+package_python2-gffutils() {
+ depends=(
+ 'python2'
+ 'python2-argcomplete'
+ 'python2-argh'
+ 'python2-pyfaidx'
+ 'python2-simplejson'
+ 'python2-six')
+ optdepends=(
+ 'bedtools: for genomic interval arithemtic'
+ 'python2-biopython: for sequence manipulation'
+ 'python2-pybedtools: wrapper for bedtools')
+
+ cd "${_name}"-"${pkgver}"-py2
+ python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/COPYING
+
+ mv "${pkgdir}"/usr/bin/"${_name}"-cli "${pkgdir}"/usr/bin/"${_name}"-cli2
+}
+
+package_python-gffutils() {
+ depends=(
+ 'python'
+ 'python-argcomplete'
+ 'python-argh'
+ 'python-pyfaidx'
+ 'python-simplejson'
+ 'python-six')
+ optdepends=(
+ 'bedtools: for genomic interval arithemtic'
+ 'python-biopython: for sequence manipulation'
+ 'python-pybedtools: wrapper for bedtools')
+
+ cd "${_name}"-"${pkgver}"
+ python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/COPYING
+}