summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weißschuh2015-02-15 23:30:11 +0000
committerThomas Weißschuh2015-02-15 23:30:11 +0000
commitbf966aa1688dedcaff97ad380a74aa3afe084a4f (patch)
tree00a0f1ec12284cc3bb06082155fbcadcabd63d88
downloadaur-bf966aa1688dedcaff97ad380a74aa3afe084a4f.tar.gz
add ggplot
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6fcdff47440
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-ggplot
+ pkgdesc = ggplot for python
+ pkgver = 0.5.8
+ pkgrel = 1
+ url = https://github.com/yhat/ggplot/
+ arch = any
+ license = BSD
+ depends = python-matplotlib
+ depends = python-statsmodels
+ depends = python-brewer2mpl
+ source = http://pypi.python.org/packages/source/g/ggplot/ggplot-0.5.8.tar.gz
+ sha256sums = 3348596865bdb3d654c0fc3823c43cfaa660a145a6b38428b5d846da84ae3096
+
+pkgname = python-ggplot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2186cee5b6b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Thomas Weißschuh <thomas t-8ch.de>
+
+pkgname=python-ggplot
+pkgver=0.5.8
+pkgrel=1
+pkgdesc="ggplot for python"
+arch=('any')
+url="https://github.com/yhat/ggplot/"
+license=('BSD')
+depends=('python-matplotlib' 'python-statsmodels' 'python-brewer2mpl')
+source=("http://pypi.python.org/packages/source/g/ggplot/ggplot-${pkgver}.tar.gz")
+
+
+build() {
+ cd "$srcdir/ggplot-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/ggplot-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+sha256sums=('3348596865bdb3d654c0fc3823c43cfaa660a145a6b38428b5d846da84ae3096')