summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-03-13 16:14:29 -0500
committerLuis Martinez2022-03-13 16:14:29 -0500
commit3d96cfdf3172cf03af3be5f7fa914796656c65a5 (patch)
tree0cd4866fb2ac68d5e88d3792f8cf402aea1b2853
parent1f9db4f6249288561c78dac91d7d26f133bbd896 (diff)
downloadaur-3d96cfdf3172cf03af3be5f7fa914796656c65a5.tar.gz
package cleanup
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 39 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a26920275129..f035d195a4b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,23 @@
pkgbase = python-ghtopdep
pkgdesc = CLI tool for sorting dependents repositories and packages by stars.
pkgver = 0.3.13
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/github-tooling/ghtopdep
arch = any
license = MIT
- makedepends = python-setuptools
- depends = python
- provides = python-ghtopdep
- provides = ghtopdep
- source = https://files.pythonhosted.org/packages/source/g/ghtopdep/ghtopdep-0.3.13.tar.gz
- sha512sums = 142aeffc098ce0e167b8112f4950b692ea6ef888a173751433a8a79b837a4cd1c2eef9c323b8be955d21812211949ffbec6a436a3c31da1794462a3aaf33176f
+ makedepends = python-poetry
+ makedepends = python-build
+ makedepends = python-installer
+ depends = python-appdirs
+ depends = python-cachecontrol
+ depends = python-click
+ depends = python-github3.py
+ depends = python-halo
+ depends = python-pipdate
+ depends = python-requests
+ depends = python-selectolax
+ depends = python-tabulate
+ source = python-ghtopdep-0.3.13.tar.gz::https://files.pythonhosted.org/packages/source/g/ghtopdep/ghtopdep-0.3.13.tar.gz
+ sha256sums = c92026411beb38dec238871293c277b3ebb3c79d6366387bcb023aa6eed23714
pkgname = python-ghtopdep
diff --git a/PKGBUILD b/PKGBUILD
index 8043243b61ac..fa4916c73e11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,39 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Arnaud Lier <zeprofdecoding@gmail.com>
-# Maintainer: Arnaud Lier <zeprofdecoding@gmail.com>
pkgname=python-ghtopdep
-_name=${pkgname#python-}
pkgver=0.3.13
-pkgrel=1
+pkgrel=2
pkgdesc='CLI tool for sorting dependents repositories and packages by stars.'
arch=('any')
url='https://github.com/github-tooling/ghtopdep'
license=('MIT')
-depends=('python')
-makedepends=('python-setuptools')
-provides=("${pkgname}" 'ghtopdep')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha512sums=('142aeffc098ce0e167b8112f4950b692ea6ef888a173751433a8a79b837a4cd1c2eef9c323b8be955d21812211949ffbec6a436a3c31da1794462a3aaf33176f')
+depends=(
+ 'python-appdirs'
+ 'python-cachecontrol'
+ 'python-click'
+ 'python-github3.py'
+ 'python-halo'
+ 'python-pipdate'
+ 'python-requests'
+ 'python-selectolax'
+ 'python-tabulate')
+makedepends=('python-poetry' 'python-build' 'python-installer')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/g/ghtopdep/ghtopdep-$pkgver.tar.gz")
+sha256sums=('c92026411beb38dec238871293c277b3ebb3c79d6366387bcb023aa6eed23714')
build() {
- cd "$_name-$pkgver"
- python setup.py build
+ cd "ghtopdep-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "$_name-$pkgver"
- export PYTHONHASHSEED=0
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ export PYTHONHASHSEED=0
+ cd "ghtopdep-$pkgver"
+ python -m installer --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s "$_site/ghtopdep-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
}