summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Bocken2024-05-24 09:50:09 +0200
committerAlexander Bocken2024-05-24 09:50:09 +0200
commit5a16278c4e0d112a9f126ad8772ad42f5c112045 (patch)
tree158737e1eafdc184238d5c7104fc5d57a2e5569a
downloadaur-5a16278c4e0d112a9f126ad8772ad42f5c112045.tar.gz
initial commit, v. 0.4.4
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a00aa76d5184
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-gigaanalysis
+ pkgdesc = A toolbox for processing data that can be expressed as a dependent and independent variable.
+ pkgver = 0.4.4
+ pkgrel = 1
+ url = https://github.com/alexeatscake/gigaanalysis
+ arch = any
+ license = BSD-3-Clause
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python>=3.7.7
+ depends = python-numpy>=1.21.2
+ depends = python-pandas>=1.3.4
+ depends = python-matplotlib>=3.4.3
+ depends = python-h5py>=2.10.0
+ source = https://files.pythonhosted.org/packages/source/g/gigaanalysis/gigaanalysis-0.4.4.tar.gz
+ sha256sums = f5c90f1ce2e8749477109ea95a96842e1c00f2e02c394994f24d36fd376e78f4
+
+pkgname = python-gigaanalysis
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22b8a3596afb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Alexander Bocken <alexander@bocken.org>
+
+_name=gigaanalysis
+pkgname=python-${_name,,}
+pkgver=0.4.4
+pkgrel=1
+pkgdesc="A toolbox for processing data that can be expressed as a dependent and independent variable."
+arch=('any')
+url="https://github.com/alexeatscake/gigaanalysis"
+license=('BSD-3-Clause')
+depends=('python>=3.7.7'
+ 'python-numpy>=1.21.2'
+ 'python-pandas>=1.3.4'
+ 'python-matplotlib>=3.4.3'
+ 'python-h5py>=2.10.0'
+)
+makedepends=('python-installer' 'python-wheel' 'python-build')
+
+source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
+sha256sums=('f5c90f1ce2e8749477109ea95a96842e1c00f2e02c394994f24d36fd376e78f4')
+
+makedepends=(python-build python-installer python-wheel)
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}