summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel de Val-Borro2017-03-27 16:59:17 -0400
committerMiguel de Val-Borro2017-03-27 16:59:17 -0400
commit893f9760d098dbac1ec99972e785c53fb1a54740 (patch)
tree6bc74ca4287d7063b0533356f51339be29a07e4f
downloadaur-893f9760d098dbac1ec99972e785c53fb1a54740.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df48dcc1472b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-ginga
+ pkgdesc = A viewer for astronomical data FITS (Flexible Image Transport System) files.
+ pkgver = 2.6.2
+ pkgrel = 1
+ url = http://ejeschke.github.io/ginga/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = python
+ depends = python-astropy
+ depends = python-astropy-helpers
+ depends = python-matplotlib
+ depends = python-scipy
+ source = https://files.pythonhosted.org/packages/source/g/ginga/ginga-2.6.2.tar.gz
+ md5sums = a98559abd5532d41a7e6bd243bf9c1f3
+
+pkgname = python-ginga
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47c5ad7d3198
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Miguel de Val-Borro <miguel at archlinux dot net>
+
+pkgname=python-ginga
+pkgver=2.6.2
+pkgrel=1
+pkgdesc=" A viewer for astronomical data FITS (Flexible Image Transport System) files."
+arch=('i686' 'x86_64')
+url="http://ejeschke.github.io/ginga/"
+license=('BSD')
+depends=('python'
+ 'python-astropy'
+ 'python-astropy-helpers'
+ 'python-matplotlib'
+ 'python-scipy')
+source=("https://files.pythonhosted.org/packages/source/g/ginga/ginga-${pkgver}.tar.gz")
+md5sums=('a98559abd5532d41a7e6bd243bf9c1f3')
+
+package(){
+ cd $srcdir/ginga
+ python setup.py install --root="$pkgdir/" --optimize=1 --use-system-libraries
+}