summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcarlwgeorge2016-02-20 16:01:18 -0600
committercarlwgeorge2016-02-20 16:01:18 -0600
commit2f67eb1ab53cd32daf576f3a9178b31184eb4f83 (patch)
treef6c7fddbd620b4fa2b54faf3811463f49091ff2d
parentab4e1b0b9e422592bf0fe9512cf5abdf7b049ff0 (diff)
downloadaur-2f67eb1ab53cd32daf576f3a9178b31184eb4f83.tar.gz
1.0.2
* test suite requires git cloning, disable it
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 11 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66f51cd446dc..bdd7bee1435e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,26 @@
+# Generated by mksrcinfo v8
+# Sat Feb 20 22:00:57 UTC 2016
pkgbase = python-git
pkgdesc = Python Git Library
- pkgver = 1.0.1
- pkgrel = 4
+ pkgver = 1.0.2
+ pkgrel = 1
url = https://github.com/gitpython-developers/GitPython
arch = any
license = BSD
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://pypi.python.org/packages/source/G/GitPython/GitPython-1.0.1.tar.gz
- sha256sums = 9c88c17bbcae2a445ff64024ef13526224f70e35e38c33416be5ceb56ca7f760
+ source = https://pypi.python.org/packages/source/G/GitPython/GitPython-1.0.2.tar.gz
+ sha256sums = 85de72556781480a38897a77de5b458ae3838b0fd589593679a1b5f34d181d84
pkgname = python-git
depends = git>=1.7
depends = python-gitdb>=0.6.4
- provides = python-gitpython=1.0.1-4
+ provides = python-gitpython=1.0.2-1
conflicts = python-gitpython
pkgname = python2-git
depends = git>=1.7
depends = python2-gitdb>=0.6.4
- provides = python2-gitpython=1.0.1-4
+ provides = python2-gitpython=1.0.2-1
conflicts = python2-gitpython
diff --git a/PKGBUILD b/PKGBUILD
index 54c226c54ed0..7d23c1de26b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,17 @@
_name="GitPython"
_module="git"
-_check="disabled"
pkgname=("python-${_module}" "python2-${_module}")
-pkgver="1.0.1"
-pkgrel="4"
+pkgver="1.0.2"
+pkgrel="1"
pkgdesc="Python Git Library"
arch=("any")
url="https://github.com/gitpython-developers/${_name}"
license=("BSD")
makedepends=("python-setuptools" "python2-setuptools")
-if [[ "${_check}" == "enabled" ]]; then
- checkdepends=("python-mock"
- "python-nose"
- "python-gitdb"
- "python2-mock"
- "python2-nose"
- "python2-gitdb")
-fi
source=("https://pypi.python.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('9c88c17bbcae2a445ff64024ef13526224f70e35e38c33416be5ceb56ca7f760')
+sha256sums=('85de72556781480a38897a77de5b458ae3838b0fd589593679a1b5f34d181d84')
prepare() {
cp -a "${srcdir}/${_name}-${pkgver}" "${srcdir}/${_name}-${pkgver}-python2"
@@ -34,17 +25,6 @@ build() {
python2 setup.py build
}
-check() {
- if [[ "${_check}" == "enabled" ]]; then
- cd "${srcdir}/${_name}-${pkgver}"
- nosetests
- cd "${srcdir}/${_name}-${pkgver}-python2"
- nosetests2
- else
- echo "_check is not set to \"enabled\", skipping check()"
- fi
-}
-
package_python-git() {
depends=("git>=1.7" "python-gitdb>=0.6.4")
provides=("python-gitpython=${pkgver}-${pkgrel}")