summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-12-09 19:24:01 +0800
committerChih-Hsuan Yen2018-12-09 19:24:01 +0800
commit860e10d45e38e02a3ff346f905277a4ca44bb821 (patch)
tree3528515e79ae2e2d5410a084c35a114235b1b16b
parentf2d7bc72923e74e702d9ce515e2a235be6830319 (diff)
downloadaur-860e10d45e38e02a3ff346f905277a4ca44bb821.tar.gz
remove a merged patch
This patch is merged as https://github.com/python/cpython/commit/25648d05ac3d74c436f951579bbb716372fb8cc7
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--dont-make-libpython-readonly.patch13
3 files changed, 3 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9cdefff9e6b..9bcdda90f6d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-git
pkgdesc = Next generation of the python high-level scripting language
- pkgver = 3.8.0a0.r102733.a9655b7f71
+ pkgver = 3.8.0a0.r102932.25648d05ac
pkgrel = 1
url = https://www.python.org/
arch = i686
@@ -29,10 +29,8 @@ pkgbase = python-git
optdepends = xz: for lzma
optdepends = tk: for tkinter
source = git+https://github.com/python/cpython#branch=master
- source = dont-make-libpython-readonly.patch
source = 0001-compileall-Fix-ddir-when-recursing.patch
sha512sums = SKIP
- sha512sums = 2ef96708d5b13ae2a3d2cc62c87b4780e60ecfce914e190564492def3a11d5e56977659f41c7f9d12266e58050c766bce4e2b5d50b708eb792794fa8357920c4
sha512sums = ebd04c3b6d41321b1f0d439d356e0ce463760db55dc64109854c70d017cf56608aa19de9fc4a21bf840795ff202b4703444f9af8074b661780798c17e03089ff
pkgname = python-git
diff --git a/PKGBUILD b/PKGBUILD
index e5cdaab3b13a..01830fe3b71c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Contributor: Jason Chu <jason@archlinux.org>
pkgname=python-git
-pkgver=3.8.0a0.r102733.a9655b7f71
+pkgver=3.8.0a0.r102932.25648d05ac
pkgrel=1
_pybasever=3.8
pkgdesc="Next generation of the python high-level scripting language"
@@ -23,10 +23,8 @@ optdepends=('sqlite'
'xz: for lzma'
'tk: for tkinter')
source=("git+https://github.com/python/cpython#branch=master"
- dont-make-libpython-readonly.patch
0001-compileall-Fix-ddir-when-recursing.patch)
sha512sums=('SKIP'
- '2ef96708d5b13ae2a3d2cc62c87b4780e60ecfce914e190564492def3a11d5e56977659f41c7f9d12266e58050c766bce4e2b5d50b708eb792794fa8357920c4'
'ebd04c3b6d41321b1f0d439d356e0ce463760db55dc64109854c70d017cf56608aa19de9fc4a21bf840795ff202b4703444f9af8074b661780798c17e03089ff')
pkgver() {
@@ -40,9 +38,6 @@ pkgver() {
prepare() {
cd cpython
- # FS#45809
- patch -p1 -i ../dont-make-libpython-readonly.patch
-
# FS#59997
patch -p1 -i ../0001-compileall-Fix-ddir-when-recursing.patch
@@ -69,7 +64,6 @@ build() {
--enable-shared \
--with-threads \
--with-computed-gotos \
- --enable-optimizations \
--with-lto \
--enable-ipv6 \
--with-system-expat \
@@ -96,7 +90,7 @@ check() {
LD_LIBRARY_PATH="${srcdir}/cpython":${LD_LIBRARY_PATH} \
LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1280x720x24 -ac +extension GLX" -a -n "$servernum" \
- "${srcdir}/cpython/python" -m test.regrtest -v -uall -x test_ttk_guionly
+ "${srcdir}/cpython/python" -m test.regrtest -w -uall -x test_ttk_guionly -j -1
}
package() {
diff --git a/dont-make-libpython-readonly.patch b/dont-make-libpython-readonly.patch
deleted file mode 100644
index 92308bfe97bf..000000000000
--- a/dont-make-libpython-readonly.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/Makefile.pre.in b/Makefile.pre.in
-index ce2c0aa..7d6dcf7 100644
---- a/Makefile.pre.in
-+++ b/Makefile.pre.in
-@@ -60,7 +60,7 @@ INSTALL_DATA= @INSTALL_DATA@
- # Shared libraries must be installed with executable mode on some systems;
- # rather than figuring out exactly which, we always give them executable mode.
- # Also, making them read-only seems to be a good idea...
--INSTALL_SHARED= ${INSTALL} -m 555
-+INSTALL_SHARED= ${INSTALL} -m 755
-
- MKDIR_P= @MKDIR_P@
-