summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Milde2015-06-22 12:23:34 +0200
committerDaniel Milde2015-06-22 12:26:52 +0200
commit8ec91e946dd6a321542b7479a34820f08cdb9c22 (patch)
treede1bef154dc2c8e8f9ab71eab18c149676d49b3e
downloadaur-8ec91e946dd6a321542b7479a34820f08cdb9c22.tar.gz
initial
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD79
2 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..900b843107ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-git
+ pkgdesc = Next generation of the python high-level scripting language
+ pkgver = 89891.f38745b
+ pkgrel = 1
+ url = http://www.python.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = tk
+ makedepends = sqlite
+ makedepends = valgrind
+ depends = expat
+ depends = bzip2
+ depends = gdbm
+ depends = openssl
+ depends = libffi
+ depends = zlib
+ optdepends = tk: for tkinter
+ optdepends = sqlite
+ options = !makeflags
+ source = git://github.com/python/cpython.git
+ sha256sums = SKIP
+
+pkgname = python-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c907eed1243
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# Maintainer: Daniel Milde <daniel@milde.cz>
+# Based on python35 PKGBUILD (Samuel Damashek)
+
+pkgname=python-git
+pkgver=89891.f38745b
+pkgrel=1
+_pybasever=3.6
+_gitname=cpython
+pkgdesc="Next generation of the python high-level scripting language"
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://www.python.org/"
+depends=('expat' 'bzip2' 'gdbm' 'openssl' 'libffi' 'zlib')
+makedepends=('tk' 'sqlite' 'valgrind')
+optdepends=('tk: for tkinter' 'sqlite')
+options=('!makeflags')
+source=(git://github.com/python/cpython.git)
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/cpython"
+
+ # FS#23997
+ sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
+
+ # Ensure that we are using the system copy of various libraries (expat, zlib and libffi),
+ # rather than copies shipped in the tarball
+ rm -rf Modules/expat
+ rm -rf Modules/zlib
+ rm -rf Modules/_ctypes/{darwin,libffi}*
+
+ ./configure --prefix=/usr \
+ --enable-shared \
+ --with-threads \
+ --with-computed-gotos \
+ --enable-ipv6 \
+ --with-valgrind \
+ --with-system-expat \
+ --with-dbmliborder=gdbm:ndbm \
+ --with-system-ffi
+
+ make
+}
+
+# XXX disabled
+check_DISABLED() {
+ cd "${srcdir}/${_gitname}"
+ LD_LIBRARY_PATH="${srcdir}/${_gitname}":${LD_LIBRARY_PATH} \
+ "${srcdir}/${_gitname}/python" -m test.regrtest -x test_distutils test_site \
+ test_urllib test_uuid test_pydoc
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ # altinstall: /usr/bin/pythonX.Y but not /usr/bin/python or /usr/bin/pythonX
+ make DESTDIR="${pkgdir}" altinstall maninstall
+
+ # Work around a conflict with 3.4 the 'python' package.
+ rm "${pkgdir}/usr/lib/libpython3.so"
+ rm "${pkgdir}/usr/share/man/man1/python3.1"
+
+ # Fix FS#22552
+ ln -sf ../../libpython${_pybasever}m.so \
+ "${pkgdir}/usr/lib/python${_pybasever}/config-${_pybasever}m/libpython${_pybasever}m.so"
+
+ # Fix pycairo build
+ ln -sf python3.6m-config "${pkgdir}/usr/bin/python3.6-config"
+
+ # Clean-up reference to build directory
+ sed -i "s|$srcdir/${_gitname}:||" "$pkgdir/usr/lib/python${_pybasever}/config-${_pybasever}m/Makefile"
+
+ # License
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+pkgver() {
+ cd $_gitname
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}