summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2020-01-04 12:09:35 +0800
committerChih-Hsuan Yen2020-01-04 12:09:35 +0800
commitad4b939198ae8aa9d613ea42c5b1f902313b90eb (patch)
treefc21ba578aec046ec9ad0f541f655feddc5aa728
parent8bf3e0fd7bacbf102c38b2033936d9b667673433 (diff)
downloadaur-ad4b939198ae8aa9d613ea42c5b1f902313b90eb.tar.gz
fix building
The original issue is fixed upstream yay Ref: https://github.com/python/cpython/pull/17740
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--python-git-issue38692.diff13
3 files changed, 6 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 623726913e04..0944e0f0c6d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-git
pkgdesc = Next generation of the python high-level scripting language
- pkgver = 3.9.0a0.r105882.2582d46fbcf
+ pkgver = 3.9.0a0.r106069.e02ab59fdf
pkgrel = 1
url = https://www.python.org/
arch = x86_64
@@ -28,9 +28,7 @@ pkgbase = python-git
optdepends = xz: for lzma
optdepends = tk: for tkinter
source = git+https://github.com/python/cpython#branch=master
- source = python-git-issue38692.diff
sha512sums = SKIP
- sha512sums = bb18f476e74d969a16aa4077f01963f551b067d5dbeae80159d663dcf4f8e043f446c4c888388fbe3436d31d29401f6cbcfc74ace9257879e32b0d7731245a47
pkgname = python-git
diff --git a/PKGBUILD b/PKGBUILD
index 5158609a6051..1a9f7f0af6b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Contributor: Jason Chu <jason@archlinux.org>
pkgname=python-git
-pkgver=3.9.0a0.r105882.2582d46fbcf
+pkgver=3.9.0a0.r106069.e02ab59fdf
pkgrel=1
_pybasever=3.9
pkgdesc="Next generation of the python high-level scripting language"
@@ -22,10 +22,8 @@ optdepends=('sqlite'
'mpdecimal: for decimal'
'xz: for lzma'
'tk: for tkinter')
-source=("git+https://github.com/python/cpython#branch=master"
- $pkgname-issue38692.diff)
-sha512sums=('SKIP'
- 'bb18f476e74d969a16aa4077f01963f551b067d5dbeae80159d663dcf4f8e043f446c4c888388fbe3436d31d29401f6cbcfc74ace9257879e32b0d7731245a47')
+source=("git+https://github.com/python/cpython#branch=master")
+sha512sums=('SKIP')
pkgver() {
cd cpython
@@ -38,9 +36,6 @@ pkgver() {
prepare() {
cd cpython
- # https://bugs.python.org/issue38692
- patch -Np1 -i ../$pkgname-issue38692.diff
-
# FS#23997
sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
@@ -90,9 +85,10 @@ check() {
export servernum=99
while ! xvfb-run -a -n "$servernum" /bin/true 2>/dev/null; do servernum=$((servernum+1)); done
+ # test_socket hangs from time to time
LD_LIBRARY_PATH="${srcdir}/cpython":${LD_LIBRARY_PATH} \
LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1280x720x24 -ac +extension GLX" -a -n "$servernum" \
- "${srcdir}/cpython/python" -m test.regrtest -w -uall -x test_ttk_guionly -x test_tk -j -1
+ "${srcdir}/cpython/python" -m test.regrtest -w -uall -x test_ttk_guionly -x test_tk -x test_socket -j -1
}
package() {
diff --git a/python-git-issue38692.diff b/python-git-issue38692.diff
deleted file mode 100644
index e251ccc4e1f5..000000000000
--- a/python-git-issue38692.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/Lib/test/test_signal.py b/Lib/test/test_signal.py
-index 119e9e079a..5bee8a8e91 100644
---- a/Lib/test/test_signal.py
-+++ b/Lib/test/test_signal.py
-@@ -1284,6 +1284,8 @@ class PidfdSignalTest(unittest.TestCase):
- signal.pidfd_send_signal(0, signal.SIGINT)
- if cm.exception.errno == errno.ENOSYS:
- self.skipTest("kernel does not support pidfds")
-+ if isinstance(cm.exception, PermissionError):
-+ self.skipTest(f"pidfd_send_signal syscall blocked: {cm.exception!r}")
- self.assertEqual(cm.exception.errno, errno.EBADF)
- my_pidfd = os.open(f'/proc/{os.getpid()}', os.O_DIRECTORY)
- self.addCleanup(os.close, my_pidfd)