summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2018-01-25 01:56:21 +0800
committerYen Chi Hsuan2018-01-25 01:56:21 +0800
commitd9e40c89094ba14535d5a1f8075759490d48d157 (patch)
tree737a951e6ddb12e404a518be53935dcbfccf1865
parent21b26d95944d4608a996440cdf805f5f7a4d04d5 (diff)
downloadaur-d9e40c89094ba14535d5a1f8075759490d48d157.tar.gz
Bump to 3.7.0a0.r100826.8ded5b8037
* --with-threads is removed: https://bugs.python.org/issue31370 * headers used by nis is now provided by libtirpc: https://bugs.python.org/issue32521 * --with-system-ffi is ignored: https://bugs.python.org/issue27979
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 450fc8901fed..ee6e32bfa4f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-git
pkgdesc = Next generation of the python high-level scripting language
- pkgver = 3.7.0a0.r99720.e3510d74aa
+ pkgver = 3.7.0a0.r100826.8ded5b8037
pkgrel = 1
url = https://www.python.org/
arch = i686
@@ -21,6 +21,7 @@ pkgbase = python-git
optdepends = tk: for tkinter
optdepends = sqlite
optdepends = xz: for lzma
+ optdepends = libtirpc: for nis
options = debug
options = !strip
options = !makeflags
diff --git a/PKGBUILD b/PKGBUILD
index ab9014bc1638..93297f44ee22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Milde <daniel@milde.cz>
pkgname=python-git
-pkgver=3.7.0a0.r99720.e3510d74aa
+pkgver=3.7.0a0.r100826.8ded5b8037
pkgrel=1
_pybasever=3.7
_pkgname=cpython
@@ -11,7 +11,7 @@ license=('custom')
url="https://www.python.org/"
depends=('expat' 'bzip2' 'gdbm' 'openssl' 'libffi' 'zlib')
makedepends=('tk>=8.6.0' 'sqlite' 'valgrind' 'bluez-libs' 'xz' 'git')
-optdepends=('tk: for tkinter' 'sqlite' 'xz: for lzma')
+optdepends=('tk: for tkinter' 'sqlite' 'xz: for lzma' 'libtirpc: for nis')
options=(debug !strip !makeflags)
source=("git+https://github.com/python/cpython#branch=master")
sha256sums=('SKIP')
@@ -42,13 +42,11 @@ build() {
./configure --prefix=/usr \
--enable-shared \
- --with-threads \
--with-computed-gotos \
--enable-ipv6 \
--with-valgrind \
--with-system-expat \
- --with-dbmliborder=gdbm:ndbm \
- --with-system-ffi
+ --with-dbmliborder=gdbm:ndbm
make
}