summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2019-11-22 20:43:56 +0800
committerChih-Hsuan Yen2019-11-22 20:43:56 +0800
commite01eb86ac2c98fb50140f3f5248597f24e15bf6c (patch)
treefd3543e209b93f311b8b889afb3cea0065251a3d
parent9a07f79d65011176aed8374923591f332cfcb902 (diff)
downloadaur-e01eb86ac2c98fb50140f3f5248597f24e15bf6c.tar.gz
another workaround for test failures
The previous workaround is merged upstream [1] [1] https://github.com/python/cpython/pull/17290
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--python-git-issue38692.diff26
3 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 181fd079f1f2..129c8bde72d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-git
pkgdesc = Next generation of the python high-level scripting language
- pkgver = 3.9.0a0.r105755.7e43373317
+ pkgver = 3.9.0a0.r105870.65444cf7fe
pkgrel = 1
url = https://www.python.org/
arch = x86_64
@@ -30,7 +30,7 @@ pkgbase = python-git
source = git+https://github.com/python/cpython#branch=master
source = python-git-issue38692.diff
sha512sums = SKIP
- sha512sums = 0755b1da26bec440409b6c3246b7fcaa5d252a9ce973062ad392ce3c1b4b2826a338b86991e01dd37456e0285387f05b121397489a944682d4f13aa82645b0dc
+ sha512sums = bb18f476e74d969a16aa4077f01963f551b067d5dbeae80159d663dcf4f8e043f446c4c888388fbe3436d31d29401f6cbcfc74ace9257879e32b0d7731245a47
pkgname = python-git
diff --git a/PKGBUILD b/PKGBUILD
index ed3c3a90ebb5..9e1f93988fbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Contributor: Jason Chu <jason@archlinux.org>
pkgname=python-git
-pkgver=3.9.0a0.r105755.7e43373317
+pkgver=3.9.0a0.r105870.65444cf7fe
pkgrel=1
_pybasever=3.9
pkgdesc="Next generation of the python high-level scripting language"
@@ -25,7 +25,7 @@ optdepends=('sqlite'
source=("git+https://github.com/python/cpython#branch=master"
$pkgname-issue38692.diff)
sha512sums=('SKIP'
- '0755b1da26bec440409b6c3246b7fcaa5d252a9ce973062ad392ce3c1b4b2826a338b86991e01dd37456e0285387f05b121397489a944682d4f13aa82645b0dc')
+ 'bb18f476e74d969a16aa4077f01963f551b067d5dbeae80159d663dcf4f8e043f446c4c888388fbe3436d31d29401f6cbcfc74ace9257879e32b0d7731245a47')
pkgver() {
cd cpython
@@ -38,7 +38,7 @@ pkgver() {
prepare() {
cd cpython
- # https://bugs.python.org/issue38692#msg356235
+ # https://bugs.python.org/issue38692
patch -Np1 -i ../$pkgname-issue38692.diff
# FS#23997
diff --git a/python-git-issue38692.diff b/python-git-issue38692.diff
index 9def203aa80a..e251ccc4e1f5 100644
--- a/python-git-issue38692.diff
+++ b/python-git-issue38692.diff
@@ -1,13 +1,13 @@
---- a/Lib/test/test_posix.py 2019-11-08 18:26:13.704894779 +0800
-+++ b/Lib/test/test_posix.py 2019-11-08 18:26:34.575039504 +0800
-@@ -1474,8 +1474,8 @@
- def test_pidfd_open(self):
- with self.assertRaises(OSError) as cm:
- os.pidfd_open(-1)
-- if cm.exception.errno == errno.ENOSYS:
-- self.skipTest("system does not support pidfd_open")
-+ if cm.exception.errno in (errno.ENOSYS, errno.EPERM):
-+ self.skipTest("system does not support or allow pidfd_open")
- self.assertEqual(cm.exception.errno, errno.EINVAL)
- os.close(os.pidfd_open(os.getpid(), 0))
-
+diff --git a/Lib/test/test_signal.py b/Lib/test/test_signal.py
+index 119e9e079a..5bee8a8e91 100644
+--- a/Lib/test/test_signal.py
++++ b/Lib/test/test_signal.py
+@@ -1284,6 +1284,8 @@ class PidfdSignalTest(unittest.TestCase):
+ signal.pidfd_send_signal(0, signal.SIGINT)
+ if cm.exception.errno == errno.ENOSYS:
+ self.skipTest("kernel does not support pidfds")
++ if isinstance(cm.exception, PermissionError):
++ self.skipTest(f"pidfd_send_signal syscall blocked: {cm.exception!r}")
+ self.assertEqual(cm.exception.errno, errno.EBADF)
+ my_pidfd = os.open(f'/proc/{os.getpid()}', os.O_DIRECTORY)
+ self.addCleanup(os.close, my_pidfd)