summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2017-05-04 03:02:13 +0800
committerYen Chi Hsuan2017-05-04 03:02:13 +0800
commite02d0ef4f406a1ef6b4cde6b00232f918a50ab50 (patch)
tree55a310803367ac66ee4f69143d0e0076230e9da9
parent477509dd6adbfaeaf641a5a08d745a59dd7d4ca9 (diff)
downloadaur-e02d0ef4f406a1ef6b4cde6b00232f918a50ab50.tar.gz
Bump to 3.7.0a0.r99150.a5c62a8e9f
boot-flag.patch is no longer necessary since https://github.com/python/cpython/pull/1405
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
-rw-r--r--boot-flag.patch89
3 files changed, 6 insertions, 110 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9701ca14e938..4c0024a97129 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-git
pkgdesc = Next generation of the python high-level scripting language
- pkgver = 3.7.0a0.r98682.f15fa87e5a
+ pkgver = 3.7.0a0.r99150.a5c62a8e9f
pkgrel = 1
url = http://www.python.org/
arch = i686
@@ -19,15 +19,11 @@ pkgbase = python-git
depends = zlib
optdepends = tk: for tkinter
optdepends = sqlite
- conflicts = python-hg
- replaces = python-hg
options = debug
options = !strip
options = !makeflags
source = git+https://github.com/python/cpython#branch=master
- source = boot-flag.patch
sha256sums = SKIP
- sha256sums = 940202895732185da4548b6a1fb01ad080cd188c21a149359eb178fdcfb613f9
pkgname = python-git
diff --git a/PKGBUILD b/PKGBUILD
index 2cfbe6773bd6..d13f949aedc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Milde <daniel@milde.cz>
pkgname=python-git
-pkgver=3.7.0a0.r98682.f15fa87e5a
+pkgver=3.7.0a0.r99150.a5c62a8e9f
pkgrel=1
_pybasever=3.7
_pkgname=cpython
@@ -9,16 +9,12 @@ pkgdesc="Next generation of the python high-level scripting language"
arch=('i686' 'x86_64')
license=('custom')
url="http://www.python.org/"
-replaces=('python-hg')
-conflicts=('python-hg')
depends=('expat' 'bzip2' 'gdbm' 'openssl' 'libffi' 'zlib')
makedepends=('tk>=8.6.0' 'sqlite' 'valgrind' 'bluez-libs' 'git')
optdepends=('tk: for tkinter' 'sqlite')
options=(debug !strip !makeflags)
-source=("git+https://github.com/python/cpython#branch=master"
- 'boot-flag.patch')
-sha256sums=('SKIP'
- '940202895732185da4548b6a1fb01ad080cd188c21a149359eb178fdcfb613f9')
+source=("git+https://github.com/python/cpython#branch=master")
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -39,9 +35,6 @@ prepare() {
rm -rf Modules/expat
rm -rf Modules/zlib
rm -rf Modules/_ctypes/{darwin,libffi}*
-
- # http://bugs.python.org/issue23404
- patch -p1 -i ../boot-flag.patch
}
build() {
@@ -57,17 +50,13 @@ build() {
--with-dbmliborder=gdbm:ndbm \
--with-system-ffi
- # http://bugs.python.org/issue26662
- # `make touch` does not work with git clones: http://bugs.python.org/issue23404
- # make touch
-
- make BOOT='#'
+ make
}
package() {
cd "${srcdir}/${_pkgname}"
# altinstall: /usr/bin/pythonX.Y but not /usr/bin/python or /usr/bin/pythonX
- make BOOT='#' DESTDIR="${pkgdir}" altinstall maninstall
+ make DESTDIR="${pkgdir}" altinstall maninstall
# Work around a conflict with 3.4 the 'python' package.
rm "${pkgdir}/usr/lib/libpython3.so"
diff --git a/boot-flag.patch b/boot-flag.patch
deleted file mode 100644
index f835b1c50cc5..000000000000
--- a/boot-flag.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-diff --git a/Makefile.pre.in b/Makefile.pre.in
-index 8752a02031..a7c8c5ad1e 100644
---- a/Makefile.pre.in
-+++ b/Makefile.pre.in
-@@ -247,6 +247,10 @@ COVERAGE_INFO= $(abs_builddir)/coverage.info
- COVERAGE_REPORT=$(abs_builddir)/lcov-report
- COVERAGE_REPORT_OPTIONS=--no-branch-coverage --title "CPython lcov report"
-
-+# Run <make BOOT="#"> to avoid regenerating existing files, as an
-+# alternative to the "make touch" rule.
-+BOOT=
-+
-
- # === Definitions added by makesetup ===
-
-@@ -726,8 +730,7 @@ Python/importlib_external.h: @GENERATED_COMMENT@ $(srcdir)/Lib/importlib/_bootst
- $(srcdir)/Lib/importlib/_bootstrap_external.py Python/importlib_external.h
-
- Python/importlib.h: @GENERATED_COMMENT@ $(srcdir)/Lib/importlib/_bootstrap.py Programs/_freeze_importlib Python/marshal.c
-- ./Programs/_freeze_importlib \
-- $(srcdir)/Lib/importlib/_bootstrap.py Python/importlib.h
-+ $(BOOT)./Programs/_freeze_importlib $(srcdir)/Lib/importlib/_bootstrap.py Python/importlib.h
-
-
- ############################################################################
-@@ -788,10 +791,10 @@ Python/sysmodule.o: $(srcdir)/Python/sysmodule.c Makefile
- $(IO_OBJS): $(IO_H)
-
- $(GRAMMAR_H): @GENERATED_COMMENT@ $(GRAMMAR_INPUT) $(PGEN)
-- @$(MKDIR_P) Include
-- $(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
-+ @$(BOOT)$(MKDIR_P) Include
-+ $(BOOT)$(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
- $(GRAMMAR_C): @GENERATED_COMMENT@ $(GRAMMAR_H)
-- touch $(GRAMMAR_C)
-+ $(BOOT)touch $(GRAMMAR_C)
-
- $(PGEN): $(PGENOBJS)
- $(CC) $(OPT) $(PY_LDFLAGS) $(PGENOBJS) $(LIBS) -o $(PGEN)
-@@ -808,15 +811,15 @@ Parser/printgrammar.o: $(srcdir)/Parser/printgrammar.c
- Parser/pgenmain.o: $(srcdir)/Include/parsetok.h
-
- $(AST_H): $(AST_ASDL) $(ASDLGEN_FILES)
-- $(MKDIR_P) $(AST_H_DIR)
-- $(ASDLGEN) -h $(AST_H_DIR) $(AST_ASDL)
-+ $(BOOT)$(MKDIR_P) $(AST_H_DIR)
-+ $(BOOT)$(ASDLGEN) -h $(AST_H_DIR) $(AST_ASDL)
-
- $(AST_C): $(AST_H) $(AST_ASDL) $(ASDLGEN_FILES)
-- $(MKDIR_P) $(AST_C_DIR)
-- $(ASDLGEN) -c $(AST_C_DIR) $(AST_ASDL)
-+ $(BOOT)$(MKDIR_P) $(AST_C_DIR)
-+ $(BOOT)$(ASDLGEN) -c $(AST_C_DIR) $(AST_ASDL)
-
- $(OPCODE_H): $(srcdir)/Lib/opcode.py $(OPCODE_H_SCRIPT)
-- $(OPCODE_H_GEN)
-+ $(BOOT)$(OPCODE_H_GEN)
-
- Python/compile.o Python/symtable.o Python/ast.o: $(GRAMMAR_H) $(AST_H)
-
-@@ -869,7 +872,7 @@ Objects/dictobject.o: $(srcdir)/Objects/stringlib/eq.h $(srcdir)/Objects/dict-co
- Objects/setobject.o: $(srcdir)/Objects/stringlib/eq.h
-
- $(OPCODETARGETS_H): $(OPCODETARGETGEN_FILES)
-- $(PYTHON_FOR_GEN) $(OPCODETARGETGEN) $(OPCODETARGETS_H)
-+ $(BOOT)$(PYTHON_FOR_GEN) $(OPCODETARGETGEN) $(OPCODETARGETS_H)
-
- Python/ceval.o: $(OPCODETARGETS_H) $(srcdir)/Python/ceval_gil.h
-
-@@ -889,7 +892,7 @@ Python/pydtrace.o: $(srcdir)/Include/pydtrace.d $(DTRACE_DEPS)
-
- Objects/typeobject.o: Objects/typeslots.inc
- Objects/typeslots.inc: $(srcdir)/Include/typeslots.h $(srcdir)/Objects/typeslots.py
-- $(PYTHON_FOR_GEN) $(srcdir)/Objects/typeslots.py < $(srcdir)/Include/typeslots.h Objects/typeslots.inc
-+ $(BOOT)$(PYTHON_FOR_GEN) $(srcdir)/Objects/typeslots.py < $(srcdir)/Include/typeslots.h Objects/typeslots.inc
-
- ############################################################################
- # Header files
-@@ -1566,8 +1569,8 @@ TAGS::
-
- # This fixes up the mtimes of checked-in generated files, assuming that they
- # only *appear* to be outdated because of checkout order.
--# This is run while preparing a source release tarball, and can be run manually
--# to avoid bootstrap issues.
-+# This is run while preparing a source release tarball. It can also be run
-+# manually to avoid bootstrap issues, as an alternative to setting BOOT="#".
- touch:
- cd $(srcdir); \
- hg --config extensions.touch=Tools/hg/hgtouch.py touch -v