summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-11-13 06:48:34 +0800
committerChih-Hsuan Yen2018-11-13 06:48:34 +0800
commitf2d7bc72923e74e702d9ce515e2a235be6830319 (patch)
tree757dd3923660c2125648b1605eb55f1c273505a3
parentf2e523e4a1c2ac8eaded8458c1011b5261e98fd9 (diff)
downloadaur-f2d7bc72923e74e702d9ce515e2a235be6830319.tar.gz
re-enable previous-falling tests
These tests are fixed in https://github.com/python/cpython/pull/10327
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 6 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e00c21715fc..f9cdefff9e6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = python-git
pkgdesc = Next generation of the python high-level scripting language
- pkgver = 3.8.0a0.r102398.81574b80e9
+ pkgver = 3.8.0a0.r102733.a9655b7f71
pkgrel = 1
url = https://www.python.org/
arch = i686
arch = x86_64
license = custom
+ checkdepends = ttf-font
makedepends = tk
makedepends = sqlite
makedepends = valgrind
diff --git a/PKGBUILD b/PKGBUILD
index 2e9fecc64e9c..e5cdaab3b13a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Contributor: Jason Chu <jason@archlinux.org>
pkgname=python-git
-pkgver=3.8.0a0.r102398.81574b80e9
+pkgver=3.8.0a0.r102733.a9655b7f71
pkgrel=1
_pybasever=3.8
pkgdesc="Next generation of the python high-level scripting language"
@@ -17,6 +17,7 @@ license=('custom')
url="https://www.python.org/"
depends=('expat' 'bzip2' 'gdbm' 'openssl' 'libffi' 'zlib' 'libnsl')
makedepends=('tk' 'sqlite' 'valgrind' 'bluez-libs' 'mpdecimal' 'xz' 'git' 'llvm' 'gdb' 'xorg-server-xvfb')
+checkdepends=('ttf-font')
optdepends=('sqlite'
'mpdecimal: for decimal'
'xz: for lzma'
@@ -48,10 +49,6 @@ prepare() {
# FS#23997
sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
- # https://bugs.python.org/issue34871
- # Disable a failing test
- sed -i -e 's|def test_abs_paths_cached_None|def _test_abs_paths_cached_None|' Lib/test/test_site.py
-
# Speed up LTO
sed -i -e "s|-flto |-flto=4 |g" configure configure.ac
@@ -89,12 +86,7 @@ build() {
}
check() {
- # test_gdb is expected to fail with LTO
- # test_idle, test_tk, test_ttk_guionly segfaults since 3.6.5
-
- # https://bugs.python.org/issue34022
- # test_cmd_line_script, test_compileall, test_importlib,
- # test_multiprocessing_main_handling, test_py_compile, test_runpy
+ # test_ttk_guionly hangs under certain circumstances
cd cpython
@@ -104,8 +96,7 @@ check() {
LD_LIBRARY_PATH="${srcdir}/cpython":${LD_LIBRARY_PATH} \
LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1280x720x24 -ac +extension GLX" -a -n "$servernum" \
- "${srcdir}/cpython/python" -m test.regrtest -v -uall -x test_gdb -x test_idle -x test_tk -x test_ttk_guionly \
- -x test_cmd_line_script -x test_compileall -x test_importlib -x test_multiprocessing_main_handling -x test_py_compile -x test_runpy
+ "${srcdir}/cpython/python" -m test.regrtest -v -uall -x test_ttk_guionly
}
package() {