summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2017-02-14 16:26:45 -0500
committerbrent s2017-02-14 16:26:45 -0500
commitb1144457d8f770be9c15002c58d2f61cf249f47c (patch)
treed41f4c205d7dfdcafce44e50c78052b6981ac9ef
parent88a5be0c23f46aff97b45d23ba4a603b902b04de (diff)
downloadaur-b1144457d8f770be9c15002c58d2f61cf249f47c.tar.gz
splitpkg
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 23 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca1bf2cf4249..2b7777fd50c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
# Generated by mksrcinfo v8
-# Mon Feb 13 15:06:49 UTC 2017
+# Tue Feb 14 21:26:45 UTC 2017
pkgbase = python-gitpython
pkgdesc = Python Git Library
pkgver = 2.1.1
- pkgrel = 3
+ pkgrel = 4
url = https://pypi.python.org/pypi/GitPython
arch = i686
arch = x86_64
license = BSD
- depends = python
- depends = python-gitdb2
provides = python-gitpython
source = https://pypi.python.org/packages/21/13/8d0981cee1c5b9dd7fa9f836ed7c304891686f300572c03a49e52c07c04c/GitPython-2.1.1.tar.gz
source = GitPython-2.1.1.tar.gz.sig
@@ -17,4 +15,10 @@ pkgbase = python-gitpython
sha512sums = SKIP
pkgname = python-gitpython
+ depends = python
+ depends = python-gitdb2
+
+pkgname = python2-gitpython
+ depends = python2
+ depends = python2-gitdb2
diff --git a/PKGBUILD b/PKGBUILD
index 9f68a133c16e..1d4454a2ec3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
# News updates for packages can be followed at https://devblog.square-r00t.net
-pkgname=python-gitpython
+pkgname=('python-gitpython' 'python2-gitpython')
pkgver=2.1.1
-pkgrel=3
+pkgrel=4
pkgdesc="Python Git Library"
arch=('i686' 'x86_64')
url="https://pypi.python.org/pypi/GitPython"
license=('BSD')
-depends=('python' 'python-gitdb2')
_pkgname=GitPython
provides=("python-gitpython")
#conflicts=("python-gitpython")
@@ -17,15 +16,22 @@ install=
changelog=
noextract=()
# TODO: fix this ugly-ass shit.
+# i.e. https://files.pythonhosted.org/packages/source/g/gitpython/${_name}-${pkgver}.tar.gz"
source=("https://pypi.python.org/packages/21/13/8d0981cee1c5b9dd7fa9f836ed7c304891686f300572c03a49e52c07c04c/${_pkgname}-${pkgver}.tar.gz"
"${_pkgname}-${pkgver}.tar.gz.sig")
sha512sums=('b9f49e0c23501926647c41dd386865d0bc79eae9bb4789b12a6d5ef74d57121f4953aef55a46d324d1be9d6d01f8f087f86bdf353137ac2e3027c81da81f1fb1'
'SKIP')
-build() {
- cd "${srcdir}/${_pkgname}/src"
- make prefix=${pkgdir}/usr
+
+package_python-gitpython() {
+ depends=('python' 'python-gitdb2')
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-package() {
- install -D -m755 ${srcdir}/${_pkgname}/src/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
- install -D -m644 ${srcdir}/${_pkgname}/docs/README.html.en ${pkgdir}/usr/share/doc/${_pkgname}/README.html
+
+package_python2-gitpython() {
+ depends=('python2' 'python2-gitdb2')
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}