summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2016-11-12 12:38:52 -0500
committerbrent s2016-11-12 12:38:52 -0500
commitc98f528c04a2f5798de8a63084ea066c9207e037 (patch)
tree6e41b83c7348e84d4114b3e58a27746383020f13
parentdaf40cb9b89ab7909feec636c799d58f0947c675 (diff)
downloadaur-c98f528c04a2f5798de8a63084ea066c9207e037.tar.gz
initial commit; setting up .gitignores and skeleton PKGBUILD
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore25
-rw-r--r--GitPython-2.1.0.tar.gz.sig0
-rw-r--r--PKGBUILD42
4 files changed, 50 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4477648f76ce..91fe17798480 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
# Generated by mksrcinfo v8
-# Mon Aug 15 08:23:59 UTC 2016
+# Sat Nov 12 17:38:52 UTC 2016
pkgbase = python-gitpython
- pkgdesc = Python library used to interact with Git repositories
- pkgver = 2.0.8
+ pkgdesc = Python Git Library
+ pkgver = 2.1.0
pkgrel = 1
- url = https://github.com/gitpython-developers/GitPython
- arch = any
+ url = https://pypi.python.org/pypi/GitPython
+ arch = i686
+ arch = x86_64
license = BSD
- makedepends = python-setuptools
- depends = python-gitdb
- source = https://github.com/gitpython-developers/GitPython/archive/2.0.8/python-gitpython-2.0.8.tar.gz
- sha256sums = adbc08a2244f5f00cd8d0dc7a115b55f269ca1677799393a86d499b6a4dd513e
+ depends = python
+ provides = python-gitpython
+ source = https://pypi.python.org/packages/d7/16/e914d345d7d4e988f9196b9719a99220bad6a5dbd636162f9b5cc35f3bd6/GitPython-2.1.0.tar.gz
+ source = GitPython-2.1.0.tar.gz.sig
+ sha512sums = cf83e1357eefb8bdf1542850d66d8007d620e4050b5715dc83f4a921d36ce9ce47d0d13c5d85f2b0ff8318d2877eec2f63b931bd47417a81a538327af927da3e
+ sha512sums = SKIP
pkgname = python-gitpython
diff --git a/.gitignore b/.gitignore
index 9b97681014e9..e16177da2907 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,17 +1,18 @@
-*.zip
-*.jar
+*/
+.*.swp
+*.pkg.tar.xz
+src/
+pkg/
*.tar
+*.tar.bz2
+*.tar.xz
+*.tar.gz
*.tgz
+*.txz
+*.tbz
*.tbz2
-*.gz
-*.bz2
-*.xz
-*.gem
+*.zip
*.run
+*.7z
+*.rar
*.deb
-*.rpm
-*.sig
-*.log
-/src
-/pkg
-*.kate-swp
diff --git a/GitPython-2.1.0.tar.gz.sig b/GitPython-2.1.0.tar.gz.sig
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/GitPython-2.1.0.tar.gz.sig
diff --git a/PKGBUILD b/PKGBUILD
index 9e81eef8a542..3ecd31920f17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,32 @@
-# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
-
+# Maintainer: brent s. <bts[at]square-r00t[dot]net>
+validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
+# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
+# News updates for packages can be followed at https://devblog.square-r00t.net
pkgname=python-gitpython
-pkgver=2.0.8
+pkgver=2.1.0
pkgrel=1
-pkgdesc="Python library used to interact with Git repositories"
-arch=(any)
-url="https://github.com/gitpython-developers/GitPython"
+pkgdesc="Python Git Library"
+arch=('i686' 'x86_64')
+url="https://pypi.python.org/pypi/GitPython"
license=('BSD')
-depends=('python-gitdb')
-makedepends=('python-setuptools')
-source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-
+depends=('python')
+optdepends=('')
+makedepends=('')
+_pkgname=python-gitpython
+provides=("python-gitpython")
+#conflicts=("python-gitpython")
+install=
+changelog=
+noextract=()
+source=("https://pypi.python.org/packages/d7/16/e914d345d7d4e988f9196b9719a99220bad6a5dbd636162f9b5cc35f3bd6/GitPython-2.1.0.tar.gz"
+ "GitPython-2.1.0.tar.gz.sig")
+sha512sums=('cf83e1357eefb8bdf1542850d66d8007d620e4050b5715dc83f4a921d36ce9ce47d0d13c5d85f2b0ff8318d2877eec2f63b931bd47417a81a538327af927da3e'
+ 'SKIP')
build() {
- cd "$srcdir"/GitPython-$pkgver
- python setup.py build
+ cd "${srcdir}/${_pkgname}/src"
+ make prefix=${pkgdir}/usr
}
-
package() {
- cd "$srcdir"/GitPython-$pkgver
- python setup.py install -O1 --skip-build --root="$pkgdir"
+ install -D -m755 ${srcdir}/${_pkgname}/src/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+ install -D -m644 ${srcdir}/${_pkgname}/docs/README.html.en ${pkgdir}/usr/share/doc/${_pkgname}/README.html
}
-
-sha256sums=('adbc08a2244f5f00cd8d0dc7a115b55f269ca1677799393a86d499b6a4dd513e')