summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2016-08-15 10:33:48 +0200
committerMassimiliano Torromeo2016-08-15 10:33:48 +0200
commitdaf40cb9b89ab7909feec636c799d58f0947c675 (patch)
treedcedb22ee531cc07ac80e9de9ee8f5d694bcbf62
parent6d4c79e1a8f1c460e718d08cc4da612bcab8320b (diff)
downloadaur-daf40cb9b89ab7909feec636c799d58f0947c675.tar.gz
Version 2.0.8
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD68
3 files changed, 41 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19c489591af0..4477648f76ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Aug 15 08:23:59 UTC 2016
pkgbase = python-gitpython
- pkgdesc = Python Git Library
- pkgver = 1.0.1
- pkgrel = 2
+ pkgdesc = Python library used to interact with Git repositories
+ pkgver = 2.0.8
+ pkgrel = 1
url = https://github.com/gitpython-developers/GitPython
arch = any
license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = https://pypi.python.org/packages/source/G/GitPython/GitPython-1.0.1.tar.gz
- sha256sums = 9c88c17bbcae2a445ff64024ef13526224f70e35e38c33416be5ceb56ca7f760
+ depends = python-gitdb
+ source = https://github.com/gitpython-developers/GitPython/archive/2.0.8/python-gitpython-2.0.8.tar.gz
+ sha256sums = adbc08a2244f5f00cd8d0dc7a115b55f269ca1677799393a86d499b6a4dd513e
pkgname = python-gitpython
- depends = git>=1.7
- depends = python-gitdb>=0.6.4
-
-pkgname = python2-gitpython
- depends = git>=1.7
- depends = python2-gitdb>=0.6.4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b97681014e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+*.zip
+*.jar
+*.tar
+*.tgz
+*.tbz2
+*.gz
+*.bz2
+*.xz
+*.gem
+*.run
+*.deb
+*.rpm
+*.sig
+*.log
+/src
+/pkg
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
index 1a0a4e13abe0..9e81eef8a542 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,24 @@
-# Maintainer: Carl George < arch at cgtx dot us >
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
-_name="GitPython"
-_module="gitpython"
-_check="disabled"
-
-pkgname=("python-${_module}" "python2-${_module}")
-pkgver="1.0.1"
-pkgrel="2"
-pkgdesc="Python Git Library"
-arch=("any")
-url="https://github.com/gitpython-developers/${_name}"
-license=("BSD")
-makedepends=("python-setuptools" "python2-setuptools")
-if [[ "${_check}" == "enabled" ]]; then
- checkdepends=("python-mock"
- "python-nose"
- "python-gitdb"
- "python2-mock"
- "python2-nose"
- "python2-gitdb")
-fi
-source=("https://pypi.python.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('9c88c17bbcae2a445ff64024ef13526224f70e35e38c33416be5ceb56ca7f760')
-
-prepare() {
- cp -a "${srcdir}/${_name}-${pkgver}" "${srcdir}/${_name}-${pkgver}-python2"
-}
+pkgname=python-gitpython
+pkgver=2.0.8
+pkgrel=1
+pkgdesc="Python library used to interact with Git repositories"
+arch=(any)
+url="https://github.com/gitpython-developers/GitPython"
+license=('BSD')
+depends=('python-gitdb')
+makedepends=('python-setuptools')
+source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz")
build() {
- cd "${srcdir}/${_name}-${pkgver}"
+ cd "$srcdir"/GitPython-$pkgver
python setup.py build
- cd "${srcdir}/${_name}-${pkgver}-python2"
- python2 setup.py build
}
-check() {
- if [[ "${_check}" == "enabled" ]]; then
- cd "${srcdir}/${_name}-${pkgver}"
- nosetests
- cd "${srcdir}/${_name}-${pkgver}-python2"
- nosetests2
- else
- echo "_check is not set to \"enabled\", skipping check()"
- fi
+package() {
+ cd "$srcdir"/GitPython-$pkgver
+ python setup.py install -O1 --skip-build --root="$pkgdir"
}
-package_python-gitpython() {
- depends=("git>=1.7" "python-gitdb>=0.6.4")
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --skip-build --root="${pkgdir}" --optimize=1
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
-
-package_python2-gitpython() {
- depends=("git>=1.7" "python2-gitdb>=0.6.4")
- cd "${srcdir}/${_name}-${pkgver}-python2"
- python2 setup.py install --skip-build --root="${pkgdir}" --optimize=1
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
+sha256sums=('adbc08a2244f5f00cd8d0dc7a115b55f269ca1677799393a86d499b6a4dd513e')