summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopolon2023-09-18 23:14:09 +0200
committerPopolon2023-09-18 23:14:09 +0200
commit7fa8a89ca293c27ede3b389faf3fe68c76cfb58b (patch)
tree66066f6b0ba89aab545a85c50e3d09eae977368d
parente62dc6c66ebc2f4b7ec6d4f24e0bfd8dc690f9a5 (diff)
downloadaur-7fa8a89ca293c27ede3b389faf3fe68c76cfb58b.tar.gz
upgrade to 0.5.3
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31f287f5077d..467ce1f37c0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-glaxnimate
pkgdesc = Python bindings for Glaxnimate.
- pkgver = 0.5.2
+ pkgver = 0.5.3
pkgrel = 1
url = https://glaxnimate.mattbas.org/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 6a2d97cac472..f1e025df8eb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,10 @@
_corpname=python-glaxnimate
_pkgname='glaxnimate'
pkgname=python-glaxnimate
-pkgver=0.5.2
+_git_branch=release
+pkgver=0.5.3
pkgrel=1
+tag=2236388
pkgdesc="Python bindings for Glaxnimate."
url="https://glaxnimate.mattbas.org/"
license=('GPL3')
@@ -12,7 +14,7 @@ arch=('x86_64' 'i686' 'armv7h' 'aarch64' 'riscv32' 'riscv64')
makedepends=('git' 'qt5-base' 'python' 'zlib' 'hicolor-icon-theme' 'potrace' 'ffmpeg' 'cmake' 'qt5-tools')
depends=('python' 'qt5-base' 'potrace' 'ffmpeg')
source=(
- "$_pkgname::git+https://gitlab.com/mattbas/$_pkgname/#branch=release"
+ "$_pkgname::git+https://gitlab.com/mattbas/$_pkgname/#branch=$_git_branch"
)
sha256sums=('SKIP')
@@ -35,11 +37,12 @@ build() {
if [ ! -e build ]; then mkdir build; fi
cd build
- cmake ".." -DCMAKE_INSTALL_PREFIX=/usr
+ cmake ".." -DCMAKE_INSTALL_PREFIX=/usr -DVERSION_SUFFIX="" on cmake
make glaxnimate_python
}
package() {
+ echo "package"
cd "$srcdir/$_pkgname/build/bin/python"
- python setup.py install --prefix=/usr --root="$pkgdir"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
}