summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopolon2021-09-18 23:00:38 +0200
committerPopolon2021-09-18 23:00:38 +0200
commitfdcbb71412b06ab465337f11dfaae9bea1bae900 (patch)
tree49c699f9c3e5fa3952a421ba507f969c3122043f
downloadaur-fdcbb71412b06ab465337f11dfaae9bea1bae900.tar.gz
initial commit v0.4.5
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD45
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65b0230fa071
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = python-glaxnimate
+ pkgdesc = Python bindings for Glaxnimate.
+ pkgver = 0.4.5
+ pkgrel = 1
+ url = https://glaxnimate.mattbas.org/
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ arch = aarch64
+ arch = riscv32
+ arch = riscv64
+ license = GPL3
+ makedepends = git
+ makedepends = qt5-base
+ makedepends = python
+ makedepends = zlib
+ makedepends = hicolor-icon-theme
+ makedepends = potrace
+ makedepends = ffmpeg
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = python
+ depends = qt5-base
+ depends = potrace
+ depends = ffmpeg
+ source = glaxnimate::git+https://gitlab.com/mattbas/glaxnimate/#branch=release
+ sha256sums = SKIP
+
+pkgname = python-glaxnimate
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..225e6078e527
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Popolon <popolon@popolon.org>
+# Contributor: Sythelux Rikd <dersyth@gmail.com>
+_corpname=python-glaxnimate
+_pkgname='glaxnimate'
+pkgname=python-glaxnimate
+pkgver=0.4.5
+pkgrel=1
+pkgdesc="Python bindings for Glaxnimate."
+url="https://glaxnimate.mattbas.org/"
+license=('GPL3')
+arch=('x86_64' 'i686' 'armv7h' 'aarch64' 'riscv32' 'riscv64')
+makedepends=('git' 'qt5-base' 'python' 'zlib' 'hicolor-icon-theme' 'potrace' 'ffmpeg' 'cmake' 'qt5-tools')
+depends=('python' 'qt5-base' 'potrace' 'ffmpeg')
+source=(
+ "$_pkgname::git+https://gitlab.com/mattbas/$_pkgname/#branch=release"
+)
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$_pkgname/"
+
+ # Provide git submodules
+ git submodule init
+ git submodule update --init --recursive
+}
+
+pkgver() {
+ cd "$srcdir/$_pkgname/"
+ git describe --tags | tr - _
+}
+
+build() {
+ cd "$srcdir/$_pkgname/"
+
+ if [ ! -e build ]; then mkdir build; fi
+ cd build
+ cmake ".." -DCMAKE_INSTALL_PREFIX=/usr
+ make glaxnimate_python
+# make translations
+}
+
+package() {
+ cd "$srcdir/$_pkgname/build/bin/python"
+ python setup.py install --prefix=/usr --root="$pkgdir"
+}