summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAetf2017-04-03 19:50:03 -0400
committerAetf2017-04-03 19:50:03 -0400
commitc6ddd1165c1d60bfe7fb8d6f47e45b1d712dc0c3 (patch)
tree32b156d7cbe206e7128e54681578077ff391cfe1
downloadaur-c6ddd1165c1d60bfe7fb8d6f47e45b1d712dc0c3.tar.gz
Initial
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD24
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0add2318656
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Apr 3 23:49:53 UTC 2017
+pkgbase = python-globus-sdk
+ pkgdesc = This SDK provides a convenient Pythonic interface to Globus REST APIs, including the Transfer API and the Globus Auth API.
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = https://github.com/globus/globus-sdk-python
+ arch = any
+ license = Apache
+ depends = python
+ depends = python-six
+ depends = python-requests
+ source = https://files.pythonhosted.org/packages/source/g/globus-sdk/globus-sdk-0.7.1.tar.gz
+ sha256sums = f6dbf39c19b48c7b4537b2bf831f2b5dd555b336e9ff760350bc66440cb85c56
+
+pkgname = python-globus-sdk
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8db5aa808c80
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+# Ignore downloaded source files
+*.tar.gz
+*.tar.xz
+*.tgz
+
+# Ignore packages
+*.pkg.tar.xz
+
+# Ignore log files
+*.log
+
+# Ignore all subdirs
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17c73a6e2988
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Aetf <aetf@unlimitedcodeworks.xyz>
+pkgname=python-globus-sdk
+_pkgname=globus-sdk
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="This SDK provides a convenient Pythonic interface to Globus REST APIs, including the Transfer API and the Globus Auth API."
+arch=(any)
+url="https://github.com/globus/globus-sdk-python"
+license=('Apache')
+depends=('python' 'python-six' 'python-requests')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('f6dbf39c19b48c7b4537b2bf831f2b5dd555b336e9ff760350bc66440cb85c56')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ # don't install tests package
+ sed -sie 's/find_packages()/find_packages(exclude=["tests.*", "tests"])/' setup.py
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+