summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-09-14 18:03:11 +0800
committerUniversebenzene2022-09-14 18:03:11 +0800
commitf2bb57201124052574d53b57ce0c74fefab7d763 (patch)
tree672c9ac51170c003b50d9de4a16310e70e78df88
parent6fd7a16dc566eda6e5a1c2c7dde0bebc57c59ed0 (diff)
downloadaur-f2bb57201124052574d53b57ce0c74fefab7d763.tar.gz
Update to version 0.11.6.post1
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD107
2 files changed, 57 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fcee0541b1fb..19470c918222 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,38 +1,16 @@
pkgbase = python-glymur
pkgdesc = Tools for accessing JPEG2000 files
- pkgver = 0.11.5
+ pkgver = 0.11.6.post1
pkgrel = 1
url = https://glymur.readthedocs.org
arch = any
license = MIT
- checkdepends = python-pytest
- checkdepends = python-numpy
- checkdepends = python-lxml
- checkdepends = openjpeg2
- checkdepends = python-scikit-image
- checkdepends = python-gdal
makedepends = python-setuptools
makedepends = python-wheel
makedepends = python-build
makedepends = python-installer
- makedepends = python-numpydoc
- makedepends = python-sphinx_rtd_theme
- source = https://files.pythonhosted.org/packages/source/G/Glymur/Glymur-0.11.5.tar.gz
- source = https://github.com/quintusdias/glymur/raw/master/tests/data/0220000800_uuid.dat
- source = https://raw.githubusercontent.com/quintusdias/glymur/master/docs/source/whatsnew/0.10.rst
- source = https://raw.githubusercontent.com/quintusdias/glymur/master/docs/source/whatsnew/0.11.rst
- source = https://raw.githubusercontent.com/quintusdias/glymur/master/tests/data/issue555.xmp
- source = https://github.com/quintusdias/glymur/raw/master/tests/data/issue549.dat
- source = https://github.com/quintusdias/glymur/raw/master/tests/data/issue982.j2k
- source = https://github.com/quintusdias/glymur/raw/master/tests/data/uint16.j2k
- md5sums = 3481764cbeff8b80cb43fac89d39fd72
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ source = https://files.pythonhosted.org/packages/source/G/Glymur/Glymur-0.11.6.post1.tar.gz
+ md5sums = aee2b9df873dd70e7f3261fe0d05cfee
pkgname = python-glymur
depends = python-numpy
@@ -43,6 +21,3 @@ pkgname = python-glymur
optdepends = python-gdal
optdepends = python-scikit-image
optdepends = python-glymur-doc: Documentation for Python Glymur
-
-pkgname = python-glymur-doc
- pkgdesc = Documentation for Python Glymur module
diff --git a/PKGBUILD b/PKGBUILD
index 94ab1c0f78f8..5e08843d6d3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,9 @@
pkgbase=python-glymur
#_pyname=${pkgbase#python-}
_pyname=Glymur
-pkgname=('python-glymur' 'python-glymur-doc')
-pkgver=0.11.5
+pkgname=('python-glymur')
+#'python-glymur-doc')
+pkgver=0.11.6.post1
pkgrel=1
pkgdesc="Tools for accessing JPEG2000 files"
arch=('any')
@@ -14,61 +15,61 @@ license=('MIT')
makedepends=('python-setuptools'
'python-wheel'
'python-build'
- 'python-installer'
- 'python-numpydoc'
- 'python-sphinx_rtd_theme')
-checkdepends=('python-pytest'
- 'python-numpy'
- 'python-lxml'
- 'openjpeg2'
- 'python-scikit-image'
- 'python-gdal')
-source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
- "https://github.com/quintusdias/glymur/raw/master/tests/data/0220000800_uuid.dat"
- "https://raw.githubusercontent.com/quintusdias/glymur/master/docs/source/whatsnew/0.10.rst"
- "https://raw.githubusercontent.com/quintusdias/glymur/master/docs/source/whatsnew/0.11.rst"
- "https://raw.githubusercontent.com/quintusdias/glymur/master/tests/data/issue555.xmp"
- "https://github.com/quintusdias/glymur/raw/master/tests/data/issue549.dat"
- "https://github.com/quintusdias/glymur/raw/master/tests/data/issue982.j2k"
- "https://github.com/quintusdias/glymur/raw/master/tests/data/uint16.j2k")
-md5sums=('3481764cbeff8b80cb43fac89d39fd72'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+ 'python-installer')
+# 'python-numpydoc'
+# 'python-sphinx_rtd_theme')
+#checkdepends=('python-pytest'
+# 'python-numpy'
+# 'python-lxml'
+# 'openjpeg2'
+# 'python-scikit-image'
+# 'python-gdal')
+source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+# "https://github.com/quintusdias/glymur/raw/master/tests/data/0220000800_uuid.dat"
+# "https://raw.githubusercontent.com/quintusdias/glymur/master/docs/source/whatsnew/0.10.rst"
+# "https://raw.githubusercontent.com/quintusdias/glymur/master/docs/source/whatsnew/0.11.rst"
+# "https://raw.githubusercontent.com/quintusdias/glymur/master/tests/data/issue555.xmp"
+# "https://github.com/quintusdias/glymur/raw/master/tests/data/issue549.dat"
+# "https://github.com/quintusdias/glymur/raw/master/tests/data/issue982.j2k"
+# "https://github.com/quintusdias/glymur/raw/master/tests/data/uint16.j2k")
+md5sums=('aee2b9df873dd70e7f3261fe0d05cfee')
+# 'SKIP'
+# 'SKIP'
+# 'SKIP'
+# 'SKIP'
+# 'SKIP'
+# 'SKIP'
+# 'SKIP')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
}
-prepare() {
- cd ${srcdir}/${_pyname}-${pkgver}
-
- ln -rs ${srcdir}/issue* tests/data
- ln -rs ${srcdir}/0220* tests/data
- ln -rs ${srcdir}/uint* tests/data
- ln -rs ${srcdir}/0.10.rst docs/source/whatsnew
- ln -rs ${srcdir}/0.11.rst docs/source/whatsnew
-}
+#prepare() {
+# cd ${srcdir}/${_pyname}-${pkgver}
+#
+# ln -rs ${srcdir}/issue* tests/data
+# ln -rs ${srcdir}/0220* tests/data
+# ln -rs ${srcdir}/uint* tests/data
+# ln -rs ${srcdir}/0.10.rst docs/source/whatsnew
+# ln -rs ${srcdir}/0.11.rst docs/source/whatsnew
+#}
build() {
cd ${srcdir}/${_pyname}-${pkgver}
python -m build --wheel --no-isolation
- msg "Building Docs"
- cd ${srcdir}/${_pyname}-${pkgver}/docs
- mkdir source/_static
- PYTHONPATH="../build/lib" make html
+# msg "Building Docs"
+# cd ${srcdir}/${_pyname}-${pkgver}/docs
+# mkdir source/_static
+# PYTHONPATH="../build/lib" make html
}
-check() {
- cd ${srcdir}/${_pyname}-${pkgver}
-
- pytest || warning "Tests failed"
-}
+#check() {
+# cd ${srcdir}/${_pyname}-${pkgver}
+#
+# pytest || warning "Tests failed"
+#}
package_python-glymur() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -84,11 +85,11 @@ package_python-glymur() {
rm -r "${pkgdir}/usr/lib/python$(get_pyver .)/site-packages/tests"/*
}
-package_python-glymur-doc() {
- pkgdesc="Documentation for Python Glymur module"
- cd ${srcdir}/${_pyname}-${pkgver}/docs/build
-
- install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../../LICENSE.txt
- install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
- cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
-}
+#package_python-glymur-doc() {
+# pkgdesc="Documentation for Python Glymur module"
+# cd ${srcdir}/${_pyname}-${pkgver}/docs/build
+#
+# install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../../LICENSE.txt
+# install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+# cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
+#}