summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-05-03 22:35:39 +0300
committerCaleb Maclennan2023-05-03 22:35:39 +0300
commit0ef0e784d6f93239a363d6460856f0203ba399fe (patch)
tree8802f576a75a09974ee64a277cc6bafdf3b6755a
parent213e664b6dc5fc9ab6e2ff52a57e32cfaad2d453 (diff)
downloadaur-0ef0e784d6f93239a363d6460856f0203ba399fe.tar.gz
upgpkg: python-glyphconstruction 0.8.3-3
Rebuild for Python 3.11, normalize PEP517 build tooling
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c512c7c4a2f..b95c52d0b3c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = python-glyphconstruction
pkgdesc = a simple, powerful, human-readable language for describing how glyph shapes are built
pkgver = 0.8.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/typemytype/GlyphConstruction
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python
source = GlyphConstruction-d7c7dd5ffe8a48d089c49206197a9091886fcb10.tar.gz::https://github.com/typemytype/GlyphConstruction/archive/d7c7dd5ffe8a48d089c49206197a9091886fcb10.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 9fb38159a3dc..7c8bd9575b2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,14 @@ _project=GlyphConstruction
pkgname=python-$_pipname
pkgver=0.8.3
_sha=d7c7dd5ffe8a48d089c49206197a9091886fcb10
-pkgrel=2
+pkgrel=3
pkgdesc='a simple, powerful, human-readable language for describing how glyph shapes are built'
arch=(any)
url="https://github.com/typemytype/$_project"
license=(MIT)
depends=(python)
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
_archive="$_project-$_sha"
source=("$_archive.tar.gz::$url/archive/$_sha.tar.gz")
sha256sums=('f0f6c48329f21aea6802dcf4d8790d1ca208723ace6e8c115c538be2c5809de5')
@@ -23,10 +24,10 @@ prepare() {
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}