summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-05-20 22:19:57 +0300
committerCaleb Maclennan2020-05-20 22:19:57 +0300
commit2cb9939c1641aba2a31506202a1a3ff53263fed8 (patch)
treed850721f6131ef7851bbc51ac4c74227b9c3c408
downloadaur-2cb9939c1641aba2a31506202a1a3ff53263fed8.tar.gz
Initial upload: python-glyphconstruction 0.8.3-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdf197c3b7ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-glyphconstruction
+ pkgdesc = a simple, powerful, human-readable language for describing how glyph shapes are built
+ pkgver = 0.8.3
+ pkgrel = 1
+ url = https://github.com/typemytype/GlyphConstruction
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = python-glyphconstruction-0.8.3.tar.gz::https://github.com/typemytype/GlyphConstruction/archive/d7c7dd5ffe8a48d089c49206197a9091886fcb10.tar.gz
+ sha256sums = f0f6c48329f21aea6802dcf4d8790d1ca208723ace6e8c115c538be2c5809de5
+
+pkgname = python-glyphconstruction
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba1c18910d7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_pipname=glyphconstruction
+_project=GlyphConstruction
+pkgname=python-$_pipname
+pkgver=0.8.3
+_sha=d7c7dd5ffe8a48d089c49206197a9091886fcb10
+pkgrel=1
+pkgdesc='a simple, powerful, human-readable language for describing how glyph shapes are built'
+arch=('any')
+url="https://github.com/typemytype/$_project"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$_sha.tar.gz")
+sha256sums=('f0f6c48329f21aea6802dcf4d8790d1ca208723ace6e8c115c538be2c5809de5')
+
+prepare() {
+ cd "$_project-$_sha"
+ sed -i -e 's!lib/glyph!Lib/glyph!' setup.py
+}
+
+build() {
+ cd "$_project-$_sha"
+ python setup.py build
+}
+
+package() {
+ cd "$_project-$_sha"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}