summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2022-07-04 13:15:01 +0300
committerCaleb Maclennan2022-07-04 13:15:01 +0300
commita0cfe3388d9f72abeed68f807dfdff2f6374d7e4 (patch)
tree9eb80fe0704de4e10b2d531f45ffdfe092df6dd9
parentb3ca83074d1a12d88cd7ba976c1772fb6d89edd5 (diff)
downloadaur-a0cfe3388d9f72abeed68f807dfdff2f6374d7e4.tar.gz
upgpkg: python-glyphslib 6.0.6-1
upstream release
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75871a52872c..9c632e00b35f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-glyphslib
pkgdesc = A bridge from Glyphs source files (.glyphs) to UFOs
- pkgver = 6.0.5
- pkgrel = 2
+ pkgver = 6.0.6
+ pkgrel = 1
url = https://github.com/googlefonts/glyphsLib
arch = any
license = Apache
@@ -10,6 +10,9 @@ pkgbase = python-glyphslib
checkdepends = python-ufo2ft
checkdepends = python-ufonormalizer
checkdepends = python-xmldiff
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-defcon
makedepends = python-setuptools-scm
depends = python
@@ -20,7 +23,7 @@ pkgbase = python-glyphslib
depends = python-unicodedata2
optdepends = python-defcon
optdepends = python-ufonormalizer
- source = https://files.pythonhosted.org/packages/source/g/glyphsLib/glyphsLib-6.0.5.tar.gz
- sha256sums = aacfd2073b177477dc6c5862854a71bee78836f8d2209c615ddfa3f1dcf5523a
+ source = https://files.pythonhosted.org/packages/source/g/glyphsLib/glyphsLib-6.0.6.tar.gz
+ sha256sums = 1787affa8eafc038d5d87df3f83af0419ed52dcd5c4888c25a1818ee972c7b53
pkgname = python-glyphslib
diff --git a/PKGBUILD b/PKGBUILD
index 45b497b568fe..f11929cf1769 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pyname=glyphsLib
pkgname=python-${_pyname,,}
-pkgver=6.0.5
-pkgrel=2
+pkgver=6.0.6
+pkgrel=1
pkgdesc='A bridge from Glyphs source files (.glyphs) to UFOs'
arch=(any)
url="https://github.com/googlefonts/$_pyname"
@@ -16,7 +16,8 @@ _pydeps=(fonttools
unicodedata2) # for fonttools[unicode]
depends=(python
"${_pydeps[@]/#/python-}")
-makedepends=(python-defcon
+makedepends=(python-{build,installer,wheel}
+ python-defcon
python-setuptools-scm)
_pycheckdeps=(lxml # for fonttools[lxml]
pytest
@@ -28,12 +29,11 @@ optdepends=(python-defcon
python-ufonormalizer)
_archive="$_pyname-$pkgver"
source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz")
-sha256sums=('aacfd2073b177477dc6c5862854a71bee78836f8d2209c615ddfa3f1dcf5523a')
-_setup='from setuptools import setup; setup();'
+sha256sums=('1787affa8eafc038d5d87df3f83af0419ed52dcd5c4888c25a1818ee972c7b53')
build() {
cd "$_archive"
- python -c "$_setup" build
+ python -m build -wn
}
check() {
@@ -48,5 +48,5 @@ check() {
package() {
cd "$_archive"
- PYTHONPATH=Lib python -c "$_setup" install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}