summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-08-12 13:17:41 -0400
committerGuillaume Horel2019-08-12 13:17:41 -0400
commitbf8d8374d3587d58804b0f34252bb329a901d4b5 (patch)
tree7d2b2b5d320d194934d04bc1bc6f0aabce18ae85
downloadaur-bf8d8374d3587d58804b0f34252bb329a901d4b5.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed9e41f2200d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-glyphslib
+ pkgdesc = A bridge from Glyphs source files (.glyphs) to UFOs
+ pkgver = 4.1.0
+ pkgrel = 1
+ url = https://github.com/googlefonts/glyphsLib
+ arch = any
+ license = Apache
+ checkdepends = python-pytest
+ checkdepends = python-ufonormalizer
+ checkdepends = python-xmldiff
+ makedepends = python-setuptools
+ depends = python
+ depends = python-defcon
+ depends = python-fonttools
+ optdepends = python-ufonormalizer
+ source = https://pypi.org/packages/source/g/glyphsLib/glyphsLib-4.1.0.zip
+ sha256sums = 0813bd8a61181bd481ac14c2a7aad536036d3a3eccaa4a6403e17cf9135f247e
+
+pkgname = python-glyphslib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3eb87ff5547
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('python-glyphslib')
+_pkgname='glyphsLib'
+pkgver='4.1.0'
+pkgrel=1
+pkgdesc="A bridge from Glyphs source files (.glyphs) to UFOs"
+url="https://github.com/googlefonts/glyphsLib"
+checkdepends=('python-pytest' 'python-ufonormalizer' 'python-xmldiff')
+depends=('python' 'python-defcon' 'python-fonttools')
+makedepends=('python-setuptools')
+optdepends=('python-ufonormalizer')
+license=('Apache')
+arch=('any')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip")
+sha256sums=('0813bd8a61181bd481ac14c2a7aad536036d3a3eccaa4a6403e17cf9135f247e')
+
+check() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py test
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}