summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2019-12-11 09:27:59 -0500
committerSolomon Choina2019-12-11 09:27:59 -0500
commitc8e7685200d11ca3dc6daf4b4f0b32335eb8b4c3 (patch)
treed6afdff0245ce9c49a9bdfa77aa416de2418caf4
parent152004a16f3f5564a250381885c0463686edc905 (diff)
downloadaur-c8e7685200d11ca3dc6daf4b4f0b32335eb8b4c3.tar.gz
fixing pkgbuild and making it a true git package
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59b5060a3c56..9a497c3b1f43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-gmusicapi-git
pkgdesc = An unofficial api for Google Play Music.
- pkgver = 11.0.0
+ pkgver = 12.1.1.r3.g57f84b6
pkgrel = 1
url = https://github.com/simon-weber/gmusicapi
arch = any
@@ -23,7 +23,7 @@ pkgbase = python-gmusicapi-git
depends = python-protobuf>=3.0.0
depends = python-decorator>=3.3.1
provides = python-gmusicapi
- source = python-gmusicapi-git::git+https://github.com/simon-weber/gmusicapi#tag=11.0.0
+ source = python-gmusicapi-git::git+https://github.com/simon-weber/gmusicapi
sha256sums = SKIP
pkgname = python-gmusicapi-git
diff --git a/PKGBUILD b/PKGBUILD
index 05b75689478e..cd2a0af5a565 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-pkgbase=('python-gmusicapi-git')
-pkgname=('python-gmusicapi-git')
+#Maintainer: Solomon Choina <shlomochoina@gmail.com>
-pkgver='11.0.0'
+pkgname='python-gmusicapi-git'
+pkgver=12.1.1.r3.g57f84b6
pkgrel=1
pkgdesc="An unofficial api for Google Play Music."
@@ -27,12 +27,18 @@ depends=(
'python-protobuf>=3.0.0'
'python-decorator>=3.3.1'
)
+
makedepends=('python-setuptools' 'git')
license=('BSD')
arch=('any')
-source=("${pkgname}::git+$url#tag=${_gitver}")
+source=("${pkgname}::git+$url")
sha256sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd "${pkgname}"
python setup.py build