summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2022-09-06 09:13:04 +0200
committerPhilipp A2022-09-06 09:13:04 +0200
commit4d2b78939a5edd4b6a290209bb8f338f2fd3c63a (patch)
treecec5e44787b7d329eb0c2b3a1e37a53e62c61e94
parent7fdd6f8deadf108c154acfe3bd9d18c65a8e4b6b (diff)
downloadaur-4d2b78939a5edd4b6a290209bb8f338f2fd3c63a.tar.gz
v1.2.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82f066b5bfdd..a9f8bb52e1c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = python-goatools
pkgdesc = Python scripts to find enrichment of GO terms
- pkgver = 1.1.6
+ pkgver = 1.2.3
pkgrel = 1
url = https://github.com/tanghaibao/goatools
arch = any
license = BSD
makedepends = python-setuptools
+ makedepends = python-installer
+ makedepends = python-build
depends = python
depends = python-pandas
depends = python-numpy
@@ -16,7 +18,7 @@ pkgbase = python-goatools
depends = python-docopt
depends = python-pydot
depends = python-requests
- source = https://files.pythonhosted.org/packages/source/g/goatools/goatools-1.1.6.tar.gz
- sha256sums = b631a6a803818673ac815ed5f1e7158d1bd98a3ce5c93b64961dc73bdea56bca
+ source = https://files.pythonhosted.org/packages/source/g/goatools/goatools-1.2.3.tar.gz
+ sha256sums = 1b5635481221e42bf2d8efc4ebdca42cd7696b52f52ce5d32fe3eb29d447cdb2
pkgname = python-goatools
diff --git a/PKGBUILD b/PKGBUILD
index 644d15735dd8..a911e76bc356 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,23 @@
_name=goatools
pkgname=python-$_name
-pkgver=1.1.6
+pkgver=1.2.3
pkgrel=1
pkgdesc='Python scripts to find enrichment of GO terms'
arch=(any)
url="https://github.com/tanghaibao/$_name"
license=(BSD)
-# it doesn’t actually use a python module called wget
depends=(python python-pandas python-numpy python-scipy python-xlsxwriter python-statsmodels python-xlrd python-docopt python-pydot python-requests)
-makedepends=(python-setuptools)
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name//-/_}/${_name//-/_}-$pkgver.tar.gz")
-sha256sums=('b631a6a803818673ac815ed5f1e7158d1bd98a3ce5c93b64961dc73bdea56bca')
+makedepends=(python-setuptools python-installer python-build)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('1b5635481221e42bf2d8efc4ebdca42cd7696b52f52ce5d32fe3eb29d447cdb2')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- cd "$srcdir/${_name//-/_}-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}