summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Ferreira2017-05-06 20:05:15 -0300
committerMarcos Ferreira2017-05-06 20:05:15 -0300
commitf05990b6054c9f0d630778ea4fd43f07b614cf24 (patch)
tree0ad310986eaafa60939669be8002ca7aa2400582
downloadaur-f05990b6054c9f0d630778ea4fd43f07b614cf24.tar.gz
first commit python-gogs-client
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66c178901bf4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-gogs-client
+ pkgdesc = Python client for Gogs server
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://github.com/unfoldingWord-dev/python-gogs-client
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-future
+ depends = python-requests
+ provides = python-gogs-client
+ conflicts = python-gogs-client
+ source = https://github.com/unfoldingWord-dev/python-gogs-client/archive/v1.0.4.tar.gz
+ sha512sums = 19d0ff2a77fe8fd12b5f87765ca7ae87102a9f8478e76eb938c9a75aa89ab42ab05ff95d2420d3737b13fae776564834ae84f41360d978f1f9fbbfca2e889192
+
+pkgname = python-gogs-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe91709f366e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Marcos Ferreira <merkkp at gmail dot com>
+
+pkgname="python-gogs-client"
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="Python client for Gogs server"
+arch=("any")
+url="https://github.com/unfoldingWord-dev/python-gogs-client"
+license=("MIT")
+depends=("python-future" "python-requests")
+makedepends=("python-setuptools")
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+source=("https://github.com/unfoldingWord-dev/python-gogs-client/archive/v${pkgver}.tar.gz")
+sha512sums=("19d0ff2a77fe8fd12b5f87765ca7ae87102a9f8478e76eb938c9a75aa89ab42ab05ff95d2420d3737b13fae776564834ae84f41360d978f1f9fbbfca2e889192")
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root=${pkgdir}
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: