summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2018-11-07 06:08:39 -0700
committerAinola2018-11-07 06:08:39 -0700
commit45e28472f516bacc95d6f1a4337093f5ea31b899 (patch)
tree48f8cdc322d5102d56547d006fd82a17b77342ed
parent454edb35fdabb417980420963443bff2c1c678a2 (diff)
downloadaur-45e28472f516bacc95d6f1a4337093f5ea31b899.tar.gz
put provides/conflicts in proper place
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e99418a1f3c8..044d0973aec1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-google-auth-httplib2-git
pkgdesc = Google Authentication Library: httplib2 transport
pkgver = r8.e7cd722
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2
arch = any
license = Apache
@@ -22,10 +22,6 @@ pkgbase = python-google-auth-httplib2-git
makedepends = python-six
makedepends = python2-six
makedepends = git
- provides = python-google-auth-httplib2
- provides = python2-google-auth-httplib2
- conflicts = python-google-auth-httplib2
- conflicts = python2-google-auth-httplib2
source = git+https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2.git
sha512sums = SKIP
@@ -33,9 +29,13 @@ pkgname = python-google-auth-httplib2-git
depends = python-google-auth
depends = python-httplib2
depends = python-six
+ provides = python-google-auth-httplib2
+ conflicts = python-google-auth-httplib2
pkgname = python2-google-auth-httplib2-git
depends = python2-google-auth
depends = python2-httplib2
depends = python2-six
+ provides = python-google-auth-httplib2
+ conflicts = python-google-auth-httplib2
diff --git a/PKGBUILD b/PKGBUILD
index 0744cb765d5b..179803077372 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=python-google-auth-httplib2-git
pkgname=(python-google-auth-httplib2-git python2-google-auth-httplib2-git)
pkgver=r8.e7cd722
-pkgrel=2
+pkgrel=3
pkgdesc="Google Authentication Library: httplib2 transport"
url="https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2"
license=('Apache')
@@ -14,8 +14,6 @@ makedepends=('python-setuptools' 'python2-setuptools' 'python-google-auth' 'pyth
checkdepends=('python-pytest-runner' 'python2-pytest-runner' 'python-mock' 'python2-mock'
'python-flask' 'python2-flask' 'python-pytest-localserver'
'python2-pytest-localserver')
-provides=('python-google-auth-httplib2' 'python2-google-auth-httplib2')
-conflicts=('python-google-auth-httplib2' 'python2-google-auth-httplib2')
source=("git+https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2.git")
sha512sums=('SKIP')
@@ -40,12 +38,14 @@ check() {
cd google-auth-library-python-httplib2
python setup.py pytest
- cd "$srcdir/google-auth-library-python-httplib2-py2"
+ cd ../google-auth-library-python-httplib2-py2
python2 setup.py pytest
}
package_python-google-auth-httplib2-git() {
depends=('python-google-auth' 'python-httplib2' 'python-six')
+ provides=('python-google-auth-httplib2')
+ conflicts=('python-google-auth-httplib2')
cd google-auth-library-python-httplib2
python setup.py install --root="$pkgdir" --optimize=1
@@ -54,6 +54,8 @@ package_python-google-auth-httplib2-git() {
package_python2-google-auth-httplib2-git() {
depends=('python2-google-auth' 'python2-httplib2' 'python2-six')
+ provides=('python-google-auth-httplib2')
+ conflicts=('python-google-auth-httplib2')
cd google-auth-library-python-httplib2-py2
python2 setup.py install --root="$pkgdir" --optimize=1