summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2018-05-01 12:56:38 -0400
committerGuillaume Horel2018-05-01 12:56:38 -0400
commitdd7a8e9fc682f20c667addf26a18d92326b77815 (patch)
treed433739156e022bc615f25848406d9c31f527411
downloadaur-dd7a8e9fc682f20c667addf26a18d92326b77815.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..714541d575d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-google-auth-oauthlib
+ pkgdesc = oauthlib integration for Google auth.
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = http://google-auth-oauthlib.readthedocs.io/en/latest/
+ arch = any
+ license = Apache
+ checkdepends = python-pytest
+ checkdepends = python-mock
+ depends = python
+ depends = python-google-auth
+ depends = python-requests-oauthlib
+ optdepends = python-click
+ source = https://pypi.org/packages/source/g/google-auth-oauthlib/google-auth-oauthlib-0.2.0.tar.gz
+ sha256sums = 226d1d0960f86ba5d9efd426a70b291eaba96f47d071657e0254ea969025728a
+
+pkgname = python-google-auth-oauthlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a2db15e3618
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('python-google-auth-oauthlib')
+_pkgname='google-auth-oauthlib'
+pkgver='0.2.0'
+pkgrel=1
+pkgdesc="oauthlib integration for Google auth."
+url="http://google-auth-oauthlib.readthedocs.io/en/latest/"
+checkdepends=('python-pytest' 'python-mock')
+depends=('python' 'python-google-auth'
+'python-requests-oauthlib')
+makedepends=()
+optdepends=('python-click')
+license=('Apache')
+arch=('any')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('226d1d0960f86ba5d9efd426a70b291eaba96f47d071657e0254ea969025728a')
+
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ pytest
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}