summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrody2023-10-12 12:55:31 +0200
committerBrody2023-10-12 12:55:31 +0200
commit1512ef1cfd28aeb6eed74a73cf8d9255b6e9288d (patch)
treecfbd505b9b22522e9d84ebdb0876ce863ec9b2d5
parentaf82c1824fb72c6c6528f214958e836c3c05e8b0 (diff)
downloadaur-1512ef1cfd28aeb6eed74a73cf8d9255b6e9288d.tar.gz
Update to 3.12.0
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore5
-rw-r--r--CHANGELOG.md21
-rw-r--r--PKGBUILD4
4 files changed, 30 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8edd02d29d6..e76ef41308ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-google-cloud-bigquery
pkgdesc = Google BigQuery API client library
- pkgver = 3.11.4
+ pkgver = 3.12.0
pkgrel = 1
url = https://github.com/googleapis/python-bigquery
changelog = CHANGELOG.md
@@ -27,7 +27,7 @@ pkgbase = python-google-cloud-bigquery
optdepends = python-pandas: pandas support
optdepends = python-snappy: fastparquet support
optdepends = python-tqdm: tqdm support
- source = python-google-cloud-bigquery-3.11.4.tar.gz::https://files.pythonhosted.org/packages/source/g/google-cloud-bigquery/google-cloud-bigquery-3.11.4.tar.gz
- sha256sums = 697df117241a2283bcbb93b21e10badc14e51c9a90800d2a7e1a3e1c7d842974
+ source = python-google-cloud-bigquery-3.12.0.tar.gz::https://files.pythonhosted.org/packages/source/g/google-cloud-bigquery/google-cloud-bigquery-3.12.0.tar.gz
+ sha256sums = 1af93c5c28a18b13190bce479b793aaae56c0ecf7e1da73b4ba5798eca054a07
pkgname = python-google-cloud-bigquery
diff --git a/.gitignore b/.gitignore
index 775e224255fe..2bf7d948c2ff 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,8 @@
+## Ignore everything
*
+
+## Except
!.gitignore
-!.SRCINFO
!PKGBUILD
+!.SRCINFO
!/CHANGELOG.md
diff --git a/CHANGELOG.md b/CHANGELOG.md
index cf64e2222778..a93bde9ebfd2 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,6 +5,27 @@
[1]: https://pypi.org/project/google-cloud-bigquery/#history
+## [3.12.0](https://github.com/googleapis/python-bigquery/compare/v3.11.4...v3.12.0) (2023-10-02)
+
+
+### Features
+
+* Add `Dataset.storage_billing_model` setter, use `client.update_dataset(ds, fields=["storage_billing_model"])` to update ([#1643](https://github.com/googleapis/python-bigquery/issues/1643)) ([5deba50](https://github.com/googleapis/python-bigquery/commit/5deba50b8c2d91d08bd5f5fb68742268c494b4a9))
+* Search statistics ([#1616](https://github.com/googleapis/python-bigquery/issues/1616)) ([b930e46](https://github.com/googleapis/python-bigquery/commit/b930e4673b0d1cceb53f683e47578d87af9361f3))
+* Widen retry predicate to include ServiceUnavailable ([#1641](https://github.com/googleapis/python-bigquery/issues/1641)) ([3e021a4](https://github.com/googleapis/python-bigquery/commit/3e021a46d387a0e3cb69913a281062fc221bb926))
+
+
+### Bug Fixes
+
+* Allow `storage_billing_model` to be explicitly set to `None` to use project default value ([#1665](https://github.com/googleapis/python-bigquery/issues/1665)) ([514d3e1](https://github.com/googleapis/python-bigquery/commit/514d3e12e5131bd589dff08893fd89bf40338ba3))
+* Relax timeout expectations ([#1645](https://github.com/googleapis/python-bigquery/issues/1645)) ([1760e94](https://github.com/googleapis/python-bigquery/commit/1760e945d16163980027fecf21113cd77ddc35a1))
+* Use isinstance() per E721, unpin flake8 ([#1659](https://github.com/googleapis/python-bigquery/issues/1659)) ([54a7769](https://github.com/googleapis/python-bigquery/commit/54a77694afcd80be4ba469c6ebb7ca8be112b04e))
+
+
+### Documentation
+
+* Revise update_table_expiration sample ([#1457](https://github.com/googleapis/python-bigquery/issues/1457)) ([03194e0](https://github.com/googleapis/python-bigquery/commit/03194e0156ed9201cb36301967c5af117d7ef29c))
+
## [3.11.4](https://github.com/googleapis/python-bigquery/compare/v3.11.3...v3.11.4) (2023-07-19)
diff --git a/PKGBUILD b/PKGBUILD
index 66c70f4f669c..d271983414d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pyname=google-cloud-bigquery
pkgname=python-google-cloud-bigquery
-pkgver=3.11.4
+pkgver=3.12.0
pkgrel=1
pkgdesc='Google BigQuery API client library'
arch=(any)
@@ -38,7 +38,7 @@ optdepends=(
changelog=CHANGELOG.md
# source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
source=(${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_pyname::1}/${_pyname}/${_pyname}-${pkgver}.tar.gz)
-sha256sums=(697df117241a2283bcbb93b21e10badc14e51c9a90800d2a7e1a3e1c7d842974)
+sha256sums=(1af93c5c28a18b13190bce479b793aaae56c0ecf7e1da73b4ba5798eca054a07)
build() {
cd ${_pyname}-${pkgver}