summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrody2024-04-04 13:22:45 +0200
committerBrody2024-04-04 13:22:45 +0200
commit43863bce356c9a63a0e551d2a4c657d31022c963 (patch)
treea4b24a8d87571e309acc6d87f16b14f19d76a0c9
parentc423f4d6ecc29eda8b6e1fa7ca62f6076e11c6dd (diff)
downloadaur-43863bce356c9a63a0e551d2a4c657d31022c963.tar.gz
Update to 3.20.1
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--CHANGELOG.md22
-rw-r--r--PKGBUILD4
4 files changed, 28 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3a87df08e66..9f7f1a015327 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-google-cloud-bigquery
pkgdesc = Google BigQuery API client library
- pkgver = 3.19.0
+ pkgver = 3.20.1
pkgrel = 1
url = https://github.com/googleapis/python-bigquery
changelog = CHANGELOG.md
@@ -27,7 +27,7 @@ pkgbase = python-google-cloud-bigquery
optdepends = python-pandas: pandas support
optdepends = python-snappy: fastparquet support
optdepends = python-tqdm: tqdm support
- source = python-google-cloud-bigquery-3.19.0.tar.gz::https://files.pythonhosted.org/packages/source/g/google-cloud-bigquery/google-cloud-bigquery-3.19.0.tar.gz
- sha256sums = 8e311dae49768e1501fcdc5e916bff4b7e169471e5707919f4a6f78a02b3b5a6
+ source = python-google-cloud-bigquery-3.20.1.tar.gz::https://files.pythonhosted.org/packages/source/g/google-cloud-bigquery/google-cloud-bigquery-3.20.1.tar.gz
+ b2sums = 6a693d0f348f90542c1ac37938ab49065ef95402e0ec1f972437e20dc5607f88b813b4af4bab33f7bb6ca970a1bd17d16c318630e2b21afdd8933c63b4857626
pkgname = python-google-cloud-bigquery
diff --git a/.gitignore b/.gitignore
index 2bf7d948c2ff..de3e75c93e8e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,4 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
-!/CHANGELOG.md
+!CHANGELOG.md
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 4cb0e1d20bdf..95af2d213693 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,6 +5,28 @@
[1]: https://pypi.org/project/google-cloud-bigquery/#history
+## [3.20.1](https://github.com/googleapis/python-bigquery/compare/v3.20.0...v3.20.1) (2024-04-01)
+
+
+### Bug Fixes
+
+* Make `pyarrow` an optional dependency post-3.20.0 yanked release ([#1879](https://github.com/googleapis/python-bigquery/issues/1879)) ([21714e1](https://github.com/googleapis/python-bigquery/commit/21714e18bad8d8d89ed5642dbdb61d14e97d5f33))
+
+## [3.20.0](https://github.com/googleapis/python-bigquery/compare/v3.19.0...v3.20.0) (2024-03-27)
+
+
+### Features
+
+* Add `fields` parameter to `set_iam_policy` for consistency with update methods ([#1872](https://github.com/googleapis/python-bigquery/issues/1872)) ([08b1e6f](https://github.com/googleapis/python-bigquery/commit/08b1e6f9c41121907c345daedbae40ece18e8b6a))
+
+
+### Bug Fixes
+
+* Correct type checking ([#1848](https://github.com/googleapis/python-bigquery/issues/1848)) ([2660dbd](https://github.com/googleapis/python-bigquery/commit/2660dbd4821a89a1e20e3e1541504a409f1979aa))
+* Update error logging when converting to pyarrow column fails ([#1836](https://github.com/googleapis/python-bigquery/issues/1836)) ([0ac6e9b](https://github.com/googleapis/python-bigquery/commit/0ac6e9bf186945832f5dcdf5a4d95667b4da223e))
+* Updates a number of optional dependencies ([#1864](https://github.com/googleapis/python-bigquery/issues/1864)) ([c2496a1](https://github.com/googleapis/python-bigquery/commit/c2496a1014a7d99e805b3d0a66e4517165bd7e01))
+* Use an allowlist instead of denylist to determine when `query_and_wait` uses `jobs.query` API ([#1869](https://github.com/googleapis/python-bigquery/issues/1869)) ([e265db6](https://github.com/googleapis/python-bigquery/commit/e265db6a6a37d13056dcaac240c2cf3975dfd644))
+
## [3.19.0](https://github.com/googleapis/python-bigquery/compare/v3.18.0...v3.19.0) (2024-03-11)
diff --git a/PKGBUILD b/PKGBUILD
index da742d9a837d..e9abadf7e27a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pyname=google-cloud-bigquery
pkgname=python-google-cloud-bigquery
-pkgver=3.19.0
+pkgver=3.20.1
pkgrel=1
pkgdesc='Google BigQuery API client library'
arch=(any)
@@ -38,7 +38,7 @@ optdepends=(
changelog=CHANGELOG.md
# source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
source=(${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_pyname::1}/${_pyname}/${_pyname}-${pkgver}.tar.gz)
-sha256sums=(8e311dae49768e1501fcdc5e916bff4b7e169471e5707919f4a6f78a02b3b5a6)
+b2sums=(6a693d0f348f90542c1ac37938ab49065ef95402e0ec1f972437e20dc5607f88b813b4af4bab33f7bb6ca970a1bd17d16c318630e2b21afdd8933c63b4857626)
build() {
cd ${_pyname}-${pkgver}