summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-08-06 13:28:33 -0500
committerLuis Martinez2022-08-06 13:29:28 -0500
commit4e6bedb67a9b4ab67ae14b5c171a43d122d1bb1f (patch)
tree2107aee39bde1b50b7dd87e31bdc7b092c8568e9
parent7a32bc29a8e3018f59009b09054434f023df6768 (diff)
downloadaur-4e6bedb67a9b4ab67ae14b5c171a43d122d1bb1f.tar.gz
update to 3.3.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md18
-rw-r--r--PKGBUILD10
3 files changed, 25 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97af89f71394..b68676304d2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-google-cloud-bigquery
pkgdesc = Google BigQuery API client library
- pkgver = 3.2.0
+ pkgver = 3.3.0
pkgrel = 1
url = https://github.com/googleapis/python-bigquery
changelog = CHANGELOG.md
@@ -29,7 +29,7 @@ pkgbase = python-google-cloud-bigquery
optdepends = python-fastparquet: fastparquet support
optdepends = python-snappy: fastparquet support
optdepends = python-llvmlite: fastparquet support
- source = python-google-cloud-bigquery-3.2.0.tar.gz::https://github.com/googleapis/python-bigquery/archive/v3.2.0.tar.gz
- sha256sums = 1f7986eec231e817704f922d61d8ec88b3411c8c04fc44e87fb77600c6c26d7f
+ source = python-google-cloud-bigquery-3.3.0.tar.gz::https://github.com/googleapis/python-bigquery/archive/v3.3.0.tar.gz
+ sha256sums = 9eb15a14b8b0f9768402ef042d2971466449f0c79313a57769dca5f4c1874635
pkgname = python-google-cloud-bigquery
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 1f999aa108a5..c7214ea167b7 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,6 +5,24 @@
[1]: https://pypi.org/project/google-cloud-bigquery/#history
+## [3.3.0](https://github.com/googleapis/python-bigquery/compare/v3.2.0...v3.3.0) (2022-07-25)
+
+
+### Features
+
+* add destination_expiration_time property to copy job ([#1277](https://github.com/googleapis/python-bigquery/issues/1277)) ([728b07c](https://github.com/googleapis/python-bigquery/commit/728b07c9177532bbbbfd1890f23e98950aea3f02))
+
+
+### Bug Fixes
+
+* require python 3.7+ ([#1284](https://github.com/googleapis/python-bigquery/issues/1284)) ([52d9f14](https://github.com/googleapis/python-bigquery/commit/52d9f14fb1d183f64a62fee1fddc0bf576a0a3e9))
+
+
+### Documentation
+
+* **samples:** add table snapshot sample ([#1274](https://github.com/googleapis/python-bigquery/issues/1274)) ([e760d1b](https://github.com/googleapis/python-bigquery/commit/e760d1bcb76561b4247adde2fd06ae0b686befb9))
+* **samples:** explicitly add bq to samples reqs, upgrade grpc to fix bug on m1 ([#1290](https://github.com/googleapis/python-bigquery/issues/1290)) ([9b7e3e4](https://github.com/googleapis/python-bigquery/commit/9b7e3e424cbd08af8b08c91e6397a3f1b7811064))
+
## [3.2.0](https://github.com/googleapis/python-bigquery/compare/v3.1.0...v3.2.0) (2022-06-06)
diff --git a/PKGBUILD b/PKGBUILD
index c81f04b7104b..bed312b3c386 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-google-cloud-bigquery
_pkg=python-bigquery
-pkgver=3.2.0
+pkgver=3.3.0
pkgrel=1
pkgdesc="Google BigQuery API client library"
arch=('any')
@@ -37,14 +37,12 @@ optdepends=(
'python-llvmlite: fastparquet support')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('1f7986eec231e817704f922d61d8ec88b3411c8c04fc44e87fb77600c6c26d7f')
+sha256sums=('9eb15a14b8b0f9768402ef042d2971466449f0c79313a57769dca5f4c1874635')
build() {
cd "$_pkg-$pkgver"
python -m build --wheel --no-isolation
- ## FIXME: man pages not building
- # cd docs
- # PYTHONPATH=../ sphinx-build -b man ./ _build
+ # PYTHONPATH="$PWD" sphinx-build -b man docs/ _build
}
package() {
@@ -52,7 +50,7 @@ package() {
cd "$_pkg-$pkgver"
python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
- # install -Dm644 docs/_build/google-cloud-bigquery.1 -t "$pkgdir/usr/share/man/man1/"
+ # install -Dm644 _build/google-cloud-bigquery.1 -t "$pkgdir/usr/share/man/man1/"
local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
install -d "$pkgdir/usr/share/licenses/$pkgname/"
ln -s \