summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrody2023-07-05 08:49:39 +0200
committerBrody2023-07-05 08:49:39 +0200
commit723459a2d7dec40e2c422e0588e7a09dedae4a7c (patch)
tree22dc821543fec45a6952116723211345b9a81120
parent390728fd61043710809eeb92d6e5c12504e3316b (diff)
downloadaur-723459a2d7dec40e2c422e0588e7a09dedae4a7c.tar.gz
Update to 3.11.3
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore8
-rw-r--r--CHANGELOG.md68
-rw-r--r--PKGBUILD100
4 files changed, 129 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d1876237232..6cdef3ff56b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-google-cloud-bigquery
pkgdesc = Google BigQuery API client library
- pkgver = 3.7.0
+ pkgver = 3.11.3
pkgrel = 1
url = https://github.com/googleapis/python-bigquery
changelog = CHANGELOG.md
@@ -27,7 +27,7 @@ pkgbase = python-google-cloud-bigquery
optdepends = python-pandas: pandas support
optdepends = python-snappy: fastparquet support
optdepends = python-tqdm: tqdm support
- source = python-google-cloud-bigquery-3.7.0.tar.gz::https://files.pythonhosted.org/packages/source/g/google-cloud-bigquery/google-cloud-bigquery-3.7.0.tar.gz
- sha256sums = cf9f543fad3aaf4871c53f56b718e1ef94a9a778b17f16890015f6fc25c328ec
+ source = python-google-cloud-bigquery-3.11.3.tar.gz::https://files.pythonhosted.org/packages/source/g/google-cloud-bigquery/google-cloud-bigquery-3.11.3.tar.gz
+ sha256sums = d4585be9e76c984ec83ef290ebeff17562d2c9f2f4f84d3015d9b7b27b499a9d
pkgname = python-google-cloud-bigquery
diff --git a/.gitignore b/.gitignore
index 924dfb95c209..775e224255fe 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,5 @@
-pkg/
-src/
-*.tar.*
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!/CHANGELOG.md
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 5eda8912d0f4..a0af641cf72c 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,6 +5,74 @@
[1]: https://pypi.org/project/google-cloud-bigquery/#history
+## [3.11.3](https://github.com/googleapis/python-bigquery/compare/v3.11.2...v3.11.3) (2023-06-27)
+
+
+### Bug Fixes
+
+* Type annotations include Optional when None is accepted ([#1554](https://github.com/googleapis/python-bigquery/issues/1554)) ([6c1ab80](https://github.com/googleapis/python-bigquery/commit/6c1ab802b09124ba837d6d5358962e3fce2d4a2c))
+
+## [3.11.2](https://github.com/googleapis/python-bigquery/compare/v3.11.1...v3.11.2) (2023-06-21)
+
+
+### Bug Fixes
+
+* Updates tests based on revised hacker_news tables ([#1591](https://github.com/googleapis/python-bigquery/issues/1591)) ([d73cf49](https://github.com/googleapis/python-bigquery/commit/d73cf495b8dfa032a43dc1d58599d0691aaa0efb))
+
+## [3.11.1](https://github.com/googleapis/python-bigquery/compare/v3.11.0...v3.11.1) (2023-06-09)
+
+
+### Documentation
+
+* Add/reformat return types for cloud RAD docs ([#1582](https://github.com/googleapis/python-bigquery/issues/1582)) ([6efdce1](https://github.com/googleapis/python-bigquery/commit/6efdce13cc3b25d37d22a856f2308daed569e637))
+
+## [3.11.0](https://github.com/googleapis/python-bigquery/compare/v3.10.0...v3.11.0) (2023-06-01)
+
+
+### Features
+
+* Add remote function options to routines ([#1558](https://github.com/googleapis/python-bigquery/issues/1558)) ([84ad11d](https://github.com/googleapis/python-bigquery/commit/84ad11d00d99d279e4e6e0fa4ca60e59575b1dad))
+
+
+### Bug Fixes
+
+* Filter None values from OpenTelemetry attributes ([#1567](https://github.com/googleapis/python-bigquery/issues/1567)) ([9ea2e21](https://github.com/googleapis/python-bigquery/commit/9ea2e21c35783782993d1ad2d3b910bbe9981ce2))
+* Handle case when expirationMs is None ([#1553](https://github.com/googleapis/python-bigquery/issues/1553)) ([fa6e13d](https://github.com/googleapis/python-bigquery/commit/fa6e13d5006caadb36899b4e2a24ca82b7f11b17))
+* Raise most recent exception when not able to fetch query job after starting the job ([#1362](https://github.com/googleapis/python-bigquery/issues/1362)) ([09cc1df](https://github.com/googleapis/python-bigquery/commit/09cc1df6babaf90ea0b0a6fd926f8013822a31ed))
+
+## [3.10.0](https://github.com/googleapis/python-bigquery/compare/v3.9.0...v3.10.0) (2023-04-18)
+
+
+### Features
+
+* Add date, datetime, time, timestamp dtype to to_dataframe ([#1547](https://github.com/googleapis/python-bigquery/issues/1547)) ([64e913d](https://github.com/googleapis/python-bigquery/commit/64e913d73832f6363466cbea5ace2337c86fa58b))
+
+## [3.9.0](https://github.com/googleapis/python-bigquery/compare/v3.8.0...v3.9.0) (2023-03-28)
+
+
+### Features
+
+* Expose query job on dbapi cursor ([#1520](https://github.com/googleapis/python-bigquery/issues/1520)) ([339eb0e](https://github.com/googleapis/python-bigquery/commit/339eb0e86040a7c30d140800f34810ffc6a7c76b))
+
+
+### Bug Fixes
+
+* Keyerror when the load_table_from_dataframe accesses a unmapped dtype dataframe index ([#1535](https://github.com/googleapis/python-bigquery/issues/1535)) ([a69348a](https://github.com/googleapis/python-bigquery/commit/a69348a558f48cfc61d03d3e8bb7f9aee48bea86))
+
+## [3.8.0](https://github.com/googleapis/python-bigquery/compare/v3.7.0...v3.8.0) (2023-03-24)
+
+
+### Features
+
+* Add bool, int, float, string dtype to to_dataframe ([#1529](https://github.com/googleapis/python-bigquery/issues/1529)) ([5e4465d](https://github.com/googleapis/python-bigquery/commit/5e4465d0975f54e8da885006686d9431ff9c5653))
+* Add default LoadJobConfig to Client ([#1526](https://github.com/googleapis/python-bigquery/issues/1526)) ([a2520ca](https://github.com/googleapis/python-bigquery/commit/a2520cabf7ec6bcb923c21e338188f1c10dc4d5d))
+* Expose configuration property on CopyJob, ExtractJob, LoadJob, QueryJob ([#1521](https://github.com/googleapis/python-bigquery/issues/1521)) ([8270a10](https://github.com/googleapis/python-bigquery/commit/8270a10df8f40750a7ac541a1781a71d7e79ce67))
+
+
+### Bug Fixes
+
+* Loosen ipywidgets restrictions further to address ipython compatibility issues ([#1531](https://github.com/googleapis/python-bigquery/issues/1531)) ([50e5026](https://github.com/googleapis/python-bigquery/commit/50e502674807b9771d7e26c0e784539bed8f9da6))
+
## [3.7.0](https://github.com/googleapis/python-bigquery/compare/v3.6.0...v3.7.0) (2023-03-06)
diff --git a/PKGBUILD b/PKGBUILD
index b7a32af2d829..bc107c172c55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,66 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
-# Contributor: Kaizhao Zhang <zhangkaizhao@gmail.com>
+# Maintainer: Brody <archfan at brodix dot de>
+_pyname=google-cloud-bigquery
pkgname=python-google-cloud-bigquery
-_pkgname="${pkgname#python-}"
-_pkg=python-bigquery
-pkgver=3.7.0
+pkgver=3.11.3
pkgrel=1
-pkgdesc="Google BigQuery API client library"
-arch=('any')
-url="https://github.com/googleapis/python-bigquery"
-license=('Apache')
+pkgdesc='Google BigQuery API client library'
+arch=(any)
+url=https://github.com/googleapis/python-bigquery
+license=(Apache)
depends=(
- 'python-dateutil'
- 'python-google-api-core'
- 'python-google-cloud-bigquery-storage'
- 'python-google-cloud-core'
- 'python-google-resumable-media'
- 'python-grpcio'
- 'python-packaging'
- 'python-protobuf'
- 'python-pyarrow'
- 'python-requests')
+ python-dateutil
+ python-google-api-core
+ python-google-cloud-bigquery-storage
+ python-google-cloud-core
+ python-google-resumable-media
+ python-grpcio
+ python-packaging
+ python-protobuf
+ python-pyarrow
+ python-requests
+)
makedepends=(
- 'ipython'
- 'python-build'
- 'python-installer'
- # 'python-recommonmark'
- 'python-setuptools'
- # 'python-sphinx'
- 'python-wheel')
+ ipython
+ python-build
+ python-installer
+ python-setuptools
+ python-wheel
+)
optdepends=(
- 'ipython'
- 'python-fastparquet: fastparquet support'
- 'python-llvmlite: fastparquet support'
- 'python-pandas: pandas support'
- 'python-snappy: fastparquet support'
- 'python-tqdm: tqdm support')
+ ipython
+ 'python-fastparquet: fastparquet support'
+ 'python-llvmlite: fastparquet support'
+ 'python-pandas: pandas support'
+ 'python-snappy: fastparquet support'
+ 'python-tqdm: tqdm support'
+)
changelog=CHANGELOG.md
-# source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/g/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('cf9f543fad3aaf4871c53f56b718e1ef94a9a778b17f16890015f6fc25c328ec')
+# source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+source=(${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_pyname::1}/${_pyname}/${_pyname}-${pkgver}.tar.gz)
+sha256sums=(d4585be9e76c984ec83ef290ebeff17562d2c9f2f4f84d3015d9b7b27b499a9d)
build() {
- cd "$_pkgname-$pkgver"
- python -m build --wheel --no-isolation
- # PYTHONPATH="$PWD" sphinx-build -b man docs/ _build
+ cd ${_pyname}-${pkgver}
+ python -m build \
+ --wheel \
+ --no-isolation
+ # PYTHONPATH="${PWD}" sphinx-build -b man docs/ _build
}
package() {
- cd "$_pkgname-$pkgver"
- python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dvm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
- # install -Dm644 _build/google-cloud-bigquery.1 -t "$pkgdir/usr/share/man/man1/"
- local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
- install -dv "$pkgdir/usr/share/licenses/$pkgname/"
- ln -sv \
- "$_site/${_pkgname//-/_}-$pkgver.dist-info/LICENSE" \
- "$pkgdir/usr/share/licenses/$pkgname/"
+ local _site=$(python -c 'import site; print(site.getsitepackages()[0])')
+
+ cd ${_pyname}-${pkgver}
+ python -m installer \
+ --destdir="${pkgdir}" \
+ dist/*.whl
+ install -Dm644 README.rst -t "${pkgdir}"/usr/share/doc/${pkgname}/
+ # install -Dm644 docs/_build/google-cloud-bigquery.1 -t "${pkgdir}"/usr/share/man/man1/
+ install -d "${pkgdir}"/usr/share/licenses/${pkgname}/
+ ln -s \
+ ${_site}/google_cloud_bigquery-${pkgver}.dist-info/LICENSE \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/
}
+
+# vim: ts=2 sw=2 et: