summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrody2023-10-31 10:27:26 +0100
committerBrody2023-10-31 10:27:26 +0100
commit777846ba57f60bd0a40202cf54b2571486a4081c (patch)
treefb43241ed73a654bf25de5ccdfcbc76a3e82c656
parent1512ef1cfd28aeb6eed74a73cf8d9255b6e9288d (diff)
downloadaur-777846ba57f60bd0a40202cf54b2571486a4081c.tar.gz
Update to 3.13.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md20
-rw-r--r--PKGBUILD4
3 files changed, 25 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e76ef41308ec..a1ad354c3060 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-google-cloud-bigquery
pkgdesc = Google BigQuery API client library
- pkgver = 3.12.0
+ pkgver = 3.13.0
pkgrel = 1
url = https://github.com/googleapis/python-bigquery
changelog = CHANGELOG.md
@@ -27,7 +27,7 @@ pkgbase = python-google-cloud-bigquery
optdepends = python-pandas: pandas support
optdepends = python-snappy: fastparquet support
optdepends = python-tqdm: tqdm support
- source = python-google-cloud-bigquery-3.12.0.tar.gz::https://files.pythonhosted.org/packages/source/g/google-cloud-bigquery/google-cloud-bigquery-3.12.0.tar.gz
- sha256sums = 1af93c5c28a18b13190bce479b793aaae56c0ecf7e1da73b4ba5798eca054a07
+ source = python-google-cloud-bigquery-3.13.0.tar.gz::https://files.pythonhosted.org/packages/source/g/google-cloud-bigquery/google-cloud-bigquery-3.13.0.tar.gz
+ sha256sums = 794ccfc93ccb0e0ad689442f896f9c82de56da0fe18a195531bb37096c2657d6
pkgname = python-google-cloud-bigquery
diff --git a/CHANGELOG.md b/CHANGELOG.md
index a93bde9ebfd2..41206fd788c0 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,6 +5,26 @@
[1]: https://pypi.org/project/google-cloud-bigquery/#history
+## [3.13.0](https://github.com/googleapis/python-bigquery/compare/v3.12.0...v3.13.0) (2023-10-30)
+
+
+### Features
+
+* Add `Model.transform_columns` property ([#1661](https://github.com/googleapis/python-bigquery/issues/1661)) ([5ceed05](https://github.com/googleapis/python-bigquery/commit/5ceed056482f6d1f2fc45e7e6b84382de45c85ed))
+* Add support for dataset.default_rounding_mode ([#1688](https://github.com/googleapis/python-bigquery/issues/1688)) ([83bc768](https://github.com/googleapis/python-bigquery/commit/83bc768b90a852d258a4805603020a296e02d2f9))
+
+
+### Bug Fixes
+
+* AccessEntry API representation parsing ([#1682](https://github.com/googleapis/python-bigquery/issues/1682)) ([a40d7ae](https://github.com/googleapis/python-bigquery/commit/a40d7ae03149708fc34c962b43a6ac198780b6aa))
+
+
+### Documentation
+
+* Remove redundant `bigquery_update_table_expiration` code sample ([#1673](https://github.com/googleapis/python-bigquery/issues/1673)) ([2dded33](https://github.com/googleapis/python-bigquery/commit/2dded33626b3de6c4ab5e1229eb4c85786b2ff53))
+* Revised `create_partitioned_table` sample ([#1447](https://github.com/googleapis/python-bigquery/issues/1447)) ([40ba859](https://github.com/googleapis/python-bigquery/commit/40ba859059c3e463e17ea7781bc5a9aff8244c5d))
+* Revised relax column mode sample ([#1467](https://github.com/googleapis/python-bigquery/issues/1467)) ([b8c9276](https://github.com/googleapis/python-bigquery/commit/b8c9276be011d971b941b583fd3d4417d438067f))
+
## [3.12.0](https://github.com/googleapis/python-bigquery/compare/v3.11.4...v3.12.0) (2023-10-02)
diff --git a/PKGBUILD b/PKGBUILD
index d271983414d6..82935f867b5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pyname=google-cloud-bigquery
pkgname=python-google-cloud-bigquery
-pkgver=3.12.0
+pkgver=3.13.0
pkgrel=1
pkgdesc='Google BigQuery API client library'
arch=(any)
@@ -38,7 +38,7 @@ optdepends=(
changelog=CHANGELOG.md
# source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
source=(${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_pyname::1}/${_pyname}/${_pyname}-${pkgver}.tar.gz)
-sha256sums=(1af93c5c28a18b13190bce479b793aaae56c0ecf7e1da73b4ba5798eca054a07)
+sha256sums=(794ccfc93ccb0e0ad689442f896f9c82de56da0fe18a195531bb37096c2657d6)
build() {
cd ${_pyname}-${pkgver}