summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-29 11:46:32 -0500
committerLuis Martinez2021-10-29 11:46:32 -0500
commit7c7adfc2bd02f41af0eac95a78cbb100d17fe8f8 (patch)
treee2411b23572fc07ff4d582b0f362f40ab2f27c6a
parente581875e3781c845c7e2421bf9764a8a988ca746 (diff)
downloadaur-7c7adfc2bd02f41af0eac95a78cbb100d17fe8f8.tar.gz
update to 2.29.0
-rw-r--r--.SRCINFO11
-rw-r--r--CHANGELOG.md21
-rw-r--r--PKGBUILD9
3 files changed, 32 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d52e6f100476..cc8ec2a4ce2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-google-cloud-bigquery
pkgdesc = Google BigQuery API client library
- pkgver = 2.28.1
+ pkgver = 2.29.0
pkgrel = 1
- url = https://pypi.org/project/google-cloud-bigquery/
+ url = https://github.com/googleapis/python-bigquery
changelog = CHANGELOG.md
arch = any
license = Apache
@@ -10,6 +10,7 @@ pkgbase = python-google-cloud-bigquery
makedepends = python-sphinx
makedepends = python-recommonmark
depends = python>=3.6
+ depends = python-dateutil>=2.7.2
depends = python-google-api-core>=1.29.0
depends = python-google-cloud-core>=1.4.1
depends = python-google-resumable-media>=0.6.0
@@ -18,13 +19,13 @@ pkgbase = python-google-cloud-bigquery
depends = python-proto-plus>=1.10.0
depends = python-protobuf>=3.12.0
depends = python-requests>=2.18.0
- optdepends = python-arrow>=1.0.0: pyarrow support
+ optdepends = python-arrow>=3.0.0: pyarrow support
optdepends = python-pandas>=0.23.0: pandas support
optdepends = python-tqdm>=4.7.4: tqdm support
optdepends = python-fastparquet: fastparquet support
optdepends = python-snappy: fastparquet support
optdepends = python-llvmlite: fastparquet support
- source = python-google-cloud-bigquery-2.28.1.tar.gz::https://github.com/googleapis/python-bigquery/archive/v2.28.1.tar.gz
- sha256sums = 7697a28f61a04020e6b906dd2a2b733e8ee2218bfac29a1c5b948c8825b38f53
+ source = python-google-cloud-bigquery-2.29.0.tar.gz::https://github.com/googleapis/python-bigquery/archive/v2.29.0.tar.gz
+ sha256sums = c142a8d1cd7055156cf82b647fb2d2762db8e7720eb3cf117f51802082a1af92
pkgname = python-google-cloud-bigquery
diff --git a/CHANGELOG.md b/CHANGELOG.md
index d15f2285182a..0d45d501d8c7 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,6 +5,27 @@
[1]: https://pypi.org/project/google-cloud-bigquery/#history
+## [2.29.0](https://www.github.com/googleapis/python-bigquery/compare/v2.28.1...v2.29.0) (2021-10-27)
+
+
+### Features
+
+* add `QueryJob.schema` property for dry run queries ([#1014](https://www.github.com/googleapis/python-bigquery/issues/1014)) ([2937fa1](https://www.github.com/googleapis/python-bigquery/commit/2937fa1386898766c561579fd39d42958182d260))
+* add session and connection properties to QueryJobConfig ([#1024](https://www.github.com/googleapis/python-bigquery/issues/1024)) ([e4c94f4](https://www.github.com/googleapis/python-bigquery/commit/e4c94f446c27eb474f30b033c1b62d11bd0acd98))
+* add support for INTERVAL data type to `list_rows` ([#840](https://www.github.com/googleapis/python-bigquery/issues/840)) ([e37380a](https://www.github.com/googleapis/python-bigquery/commit/e37380a959cbd5bb9cbbf6807f0a8ea147e0a713))
+* allow queryJob.result() to be called on a dryRun ([#1015](https://www.github.com/googleapis/python-bigquery/issues/1015)) ([685f06a](https://www.github.com/googleapis/python-bigquery/commit/685f06a5e7b5df17a53e9eb340ff04ecd1e51d1d))
+
+
+### Documentation
+
+* document ScriptStatistics and other missing resource classes ([#1023](https://www.github.com/googleapis/python-bigquery/issues/1023)) ([6679109](https://www.github.com/googleapis/python-bigquery/commit/66791093c61f262ea063d2a7950fc643915ee693))
+* fix formatting of generated client docstrings ([#1009](https://www.github.com/googleapis/python-bigquery/issues/1009)) ([f7b0ee4](https://www.github.com/googleapis/python-bigquery/commit/f7b0ee45a664295ccc9f209eeeac122af8de3c80))
+
+
+### Dependencies
+
+* allow pyarrow 6.x ([#1031](https://www.github.com/googleapis/python-bigquery/issues/1031)) ([1c2de74](https://www.github.com/googleapis/python-bigquery/commit/1c2de74a55046a343bcf9474f67100a82fb05401))
+
### [2.28.1](https://www.github.com/googleapis/python-bigquery/compare/v2.28.0...v2.28.1) (2021-10-07)
diff --git a/PKGBUILD b/PKGBUILD
index 20851e821bfd..f6bfeb99b202 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
# Contributor: Kaizhao Zhang <zhangkaizhao@gmail.com>
pkgname=python-google-cloud-bigquery
-pkgver=2.28.1
+pkgver=2.29.0
pkgrel=1
pkgdesc="Google BigQuery API client library"
arch=('any')
-url="https://pypi.org/project/google-cloud-bigquery/"
+url="https://github.com/googleapis/python-bigquery"
license=('Apache')
depends=(
'python>=3.6'
+ 'python-dateutil>=2.7.2'
'python-google-api-core>=1.29.0'
'python-google-cloud-core>=1.4.1'
'python-google-resumable-media>=0.6.0'
@@ -20,7 +21,7 @@ depends=(
'python-requests>=2.18.0')
makedepends=('python-setuptools' 'python-sphinx' 'python-recommonmark')
optdepends=(
- 'python-arrow>=1.0.0: pyarrow support'
+ 'python-arrow>=3.0.0: pyarrow support'
'python-pandas>=0.23.0: pandas support'
'python-tqdm>=4.7.4: tqdm support'
'python-fastparquet: fastparquet support'
@@ -28,7 +29,7 @@ optdepends=(
'python-llvmlite: fastparquet support')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::https://github.com/googleapis/python-bigquery/archive/v$pkgver.tar.gz")
-sha256sums=('7697a28f61a04020e6b906dd2a2b733e8ee2218bfac29a1c5b948c8825b38f53')
+sha256sums=('c142a8d1cd7055156cf82b647fb2d2762db8e7720eb3cf117f51802082a1af92')
build() {
cd "python-bigquery-$pkgver"