summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-03-31 15:35:22 -0500
committerLuis Martinez2022-03-31 15:35:51 -0500
commitdf2e247a2c9d8dd7c59a38e12403a1d8cf11100b (patch)
tree30c15bdf24d3887bc31e99395ca10d482cb7a13d
parentecfe25a51483bac9b3a4c8e2fb357eb77205383e (diff)
downloadaur-df2e247a2c9d8dd7c59a38e12403a1d8cf11100b.tar.gz
update to 3.0.1
-rw-r--r--.SRCINFO7
-rw-r--r--CHANGELOG.md8
-rw-r--r--PKGBUILD5
3 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36a9a8ac93f0..64b6d3f681d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-google-cloud-bigquery
pkgdesc = Google BigQuery API client library
- pkgver = 3.0.0
+ pkgver = 3.0.1
pkgrel = 1
url = https://github.com/googleapis/python-bigquery
changelog = CHANGELOG.md
@@ -21,7 +21,6 @@ pkgbase = python-google-cloud-bigquery
depends = python-google-resumable-media
depends = python-grpcio
depends = python-packaging
- depends = python-proto-plus
depends = python-protobuf
depends = python-requests
optdepends = ipython
@@ -30,7 +29,7 @@ pkgbase = python-google-cloud-bigquery
optdepends = python-fastparquet: fastparquet support
optdepends = python-snappy: fastparquet support
optdepends = python-llvmlite: fastparquet support
- source = python-google-cloud-bigquery-3.0.0.tar.gz::https://github.com/googleapis/python-bigquery/archive/v3.0.0.tar.gz
- sha256sums = a7424a05f836d9b8e61b7d86b197870243c85489c77dad14eef790ba86dc9e3d
+ source = python-google-cloud-bigquery-3.0.1.tar.gz::https://github.com/googleapis/python-bigquery/archive/v3.0.1.tar.gz
+ sha256sums = 3b95fc6c66b21286585d2ef585839b456f83ed38abbf470b75dc0aaf1108828d
pkgname = python-google-cloud-bigquery
diff --git a/CHANGELOG.md b/CHANGELOG.md
index c5c8447da8bc..ca99c969f6bb 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,6 +5,14 @@
[1]: https://pypi.org/project/google-cloud-bigquery/#history
+### [3.0.1](https://github.com/googleapis/python-bigquery/compare/v3.0.0...v3.0.1) (2022-03-30)
+
+
+### Bug Fixes
+
+* **deps:** raise exception when pandas is installed but db-dtypes is not ([#1191](https://github.com/googleapis/python-bigquery/issues/1191)) ([4333910](https://github.com/googleapis/python-bigquery/commit/433391097bae57dd12a93db18fc2bab573d8f128))
+* **deps:** restore dependency on python-dateutil ([#1187](https://github.com/googleapis/python-bigquery/issues/1187)) ([212d7ec](https://github.com/googleapis/python-bigquery/commit/212d7ec1f0740d04c26fb3ceffc9a4dd9eed6756))
+
## [3.0.0](https://github.com/googleapis/python-bigquery/compare/v2.34.3...v3.0.0) (2022-03-29)
diff --git a/PKGBUILD b/PKGBUILD
index e4256a796466..44e7e71c8acb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Kaizhao Zhang <zhangkaizhao@gmail.com>
pkgname=python-google-cloud-bigquery
-pkgver=3.0.0
+pkgver=3.0.1
pkgrel=1
pkgdesc="Google BigQuery API client library"
arch=('any')
@@ -17,7 +17,6 @@ depends=(
'python-google-resumable-media'
'python-grpcio'
'python-packaging'
- 'python-proto-plus'
'python-protobuf'
'python-requests')
makedepends=(
@@ -37,7 +36,7 @@ optdepends=(
'python-llvmlite: fastparquet support')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('a7424a05f836d9b8e61b7d86b197870243c85489c77dad14eef790ba86dc9e3d')
+sha256sums=('3b95fc6c66b21286585d2ef585839b456f83ed38abbf470b75dc0aaf1108828d')
build() {
cd "python-bigquery-$pkgver"