summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-01-08 16:00:17 -0600
committerLuis Martinez2023-01-08 16:00:17 -0600
commite65d1578f3621e56068b0a2261e8e1e9ec4cf218 (patch)
tree9058358920d8dd666fb4abff582dfabc28acede7
parent4e6bedb67a9b4ab67ae14b5c171a43d122d1bb1f (diff)
downloadaur-e65d1578f3621e56068b0a2261e8e1e9ec4cf218.tar.gz
update to 3.4.1
-rw-r--r--.SRCINFO24
-rw-r--r--CHANGELOG.md82
-rw-r--r--PKGBUILD39
3 files changed, 114 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b68676304d2e..0222e88aeb36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,35 @@
pkgbase = python-google-cloud-bigquery
pkgdesc = Google BigQuery API client library
- pkgver = 3.3.0
+ pkgver = 3.4.1
pkgrel = 1
url = https://github.com/googleapis/python-bigquery
changelog = CHANGELOG.md
arch = any
license = Apache
- makedepends = python-setuptools
+ makedepends = ipython
makedepends = python-build
makedepends = python-installer
- makedepends = python-wheel
- makedepends = python-sphinx
makedepends = python-recommonmark
- makedepends = ipython
- depends = python-pyarrow
+ makedepends = python-setuptools
+ makedepends = python-sphinx
+ makedepends = python-wheel
depends = python-dateutil
depends = python-google-api-core
- depends = python-google-cloud-core
depends = python-google-cloud-bigquery-storage
+ depends = python-google-cloud-core
depends = python-google-resumable-media
depends = python-grpcio
depends = python-packaging
depends = python-protobuf
+ depends = python-pyarrow
depends = python-requests
optdepends = ipython
- optdepends = python-pandas: pandas support
- optdepends = python-tqdm: tqdm support
optdepends = python-fastparquet: fastparquet support
- optdepends = python-snappy: fastparquet support
optdepends = python-llvmlite: fastparquet support
- source = python-google-cloud-bigquery-3.3.0.tar.gz::https://github.com/googleapis/python-bigquery/archive/v3.3.0.tar.gz
- sha256sums = 9eb15a14b8b0f9768402ef042d2971466449f0c79313a57769dca5f4c1874635
+ optdepends = python-pandas: pandas support
+ optdepends = python-snappy: fastparquet support
+ optdepends = python-tqdm: tqdm support
+ source = python-google-cloud-bigquery-3.4.1.tar.gz::https://files.pythonhosted.org/packages/source/g/google-cloud-bigquery/google-cloud-bigquery-3.4.1.tar.gz
+ sha256sums = 884689714d98a2364dde9c7c367e8228c7116108bbad7a6365dfde391638985b
pkgname = python-google-cloud-bigquery
diff --git a/CHANGELOG.md b/CHANGELOG.md
index c7214ea167b7..d6f0abc85a69 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,6 +5,88 @@
[1]: https://pypi.org/project/google-cloud-bigquery/#history
+## [3.4.1](https://github.com/googleapis/python-bigquery/compare/v3.4.0...v3.4.1) (2022-12-09)
+
+
+### Documentation
+
+* Add info about streaming quota limits to `insert_rows*` methods ([#1409](https://github.com/googleapis/python-bigquery/issues/1409)) ([0f08e9a](https://github.com/googleapis/python-bigquery/commit/0f08e9a8ff638e78006d71acd974de2dff89b5d9))
+
+
+### Dependencies
+
+* make pyarrow and BQ Storage optional dependencies ([e1aa921](https://github.com/googleapis/python-bigquery/commit/e1aa9218ad22f85c9a6cab8b61d013779376a582))
+
+## [3.4.0](https://github.com/googleapis/python-bigquery/compare/v3.3.6...v3.4.0) (2022-11-17)
+
+
+### Features
+
+* Add `reference_file_schema_uri` to LoadJobConfig, ExternalConfig ([#1399](https://github.com/googleapis/python-bigquery/issues/1399)) ([931285f](https://github.com/googleapis/python-bigquery/commit/931285ff85842ab07a0ef2ff9db808181ea3c5e4))
+* Add default value expression ([#1408](https://github.com/googleapis/python-bigquery/issues/1408)) ([207aa50](https://github.com/googleapis/python-bigquery/commit/207aa506ab634bdb13256fa5bd8745ec9de23290))
+* Add More Specific Type Annotations for Row Dictionaries ([#1295](https://github.com/googleapis/python-bigquery/issues/1295)) ([eb49873](https://github.com/googleapis/python-bigquery/commit/eb49873176dee478617eb50472d44703abca53b5))
+
+## [3.3.6](https://github.com/googleapis/python-bigquery/compare/v3.3.4...v3.3.6) (2022-11-02)
+
+
+### Features
+
+* Reconfigure tqdm progress bar in %%bigquery magic ([#1355](https://github.com/googleapis/python-bigquery/issues/1355)) ([506f781](https://github.com/googleapis/python-bigquery/commit/506f781c2dd775193336ab9432f32148250ed81d))
+
+
+### Bug Fixes
+
+* Corrects test for non-existent attribute ([#1395](https://github.com/googleapis/python-bigquery/issues/1395)) ([a80f436](https://github.com/googleapis/python-bigquery/commit/a80f436f2e75a8fb680316f17a22eecb31a7101d))
+* **deps:** Allow protobuf 3.19.5 ([#1379](https://github.com/googleapis/python-bigquery/issues/1379)) ([3e4a074](https://github.com/googleapis/python-bigquery/commit/3e4a074a981eb2920c5f9a711c253565d4844858))
+* **deps:** Allow pyarrow < 11 ([#1393](https://github.com/googleapis/python-bigquery/issues/1393)) ([c898546](https://github.com/googleapis/python-bigquery/commit/c898546d3292f9ec1ba6120cd3f9e2805aa087bb))
+* **deps:** Require requests>=2.21.0 ([#1388](https://github.com/googleapis/python-bigquery/issues/1388)) ([e398336](https://github.com/googleapis/python-bigquery/commit/e39833673582e4a7a34103cfc45603932c9c33b3))
+* Refactor to adapt to changes to shapely dependency ([#1376](https://github.com/googleapis/python-bigquery/issues/1376)) ([2afd278](https://github.com/googleapis/python-bigquery/commit/2afd278febe1eb247adc6278ab59903962a5bb6c))
+
+
+### Documentation
+
+* Fix typos ([#1372](https://github.com/googleapis/python-bigquery/issues/1372)) ([21cc525](https://github.com/googleapis/python-bigquery/commit/21cc525a86a06acfe73e5c5a74ec5f0b61e410f2))
+
+
+### Miscellaneous Chores
+
+* release 3.3.6 ([4fce1d9](https://github.com/googleapis/python-bigquery/commit/4fce1d93b1763703b115a0480a2b97021786aff7))
+
+## [3.3.4](https://github.com/googleapis/python-bigquery/compare/v3.3.3...v3.3.4) (2022-09-29)
+
+
+### Bug Fixes
+
+* **deps:** Require protobuf >= 3.20.2 ([#1369](https://github.com/googleapis/python-bigquery/issues/1369)) ([f13383a](https://github.com/googleapis/python-bigquery/commit/f13383a22d7b1a0a714dc1b1210ad970146bd094))
+
+## [3.3.3](https://github.com/googleapis/python-bigquery/compare/v3.3.2...v3.3.3) (2022-09-28)
+
+
+### Bug Fixes
+
+* Refactors code to account for a tdqm code deprecation ([#1357](https://github.com/googleapis/python-bigquery/issues/1357)) ([1369a9d](https://github.com/googleapis/python-bigquery/commit/1369a9d937b85d6a2a6bf9a672c71620648b1e3e))
+* Validate opentelemetry span job attributes have values ([#1327](https://github.com/googleapis/python-bigquery/issues/1327)) ([8287af1](https://github.com/googleapis/python-bigquery/commit/8287af1299169546f847126f03ae04e48890139e))
+
+
+### Documentation
+
+* **samples:** uses function (create_job) more appropriate to the described sample intent ([5aeedaa](https://github.com/googleapis/python-bigquery/commit/5aeedaa2f4e6a0200d50521dfd90f39f9a24d0cc))
+
+## [3.3.2](https://github.com/googleapis/python-bigquery/compare/v3.3.1...v3.3.2) (2022-08-16)
+
+
+### Bug Fixes
+
+* **deps:** require proto-plus >= 1.22.0 ([1de7a52](https://github.com/googleapis/python-bigquery/commit/1de7a52cb85d4876e4aa87346aff5725c8294c4e))
+* **deps:** require protobuf >=3.19, < 5.0.0 ([#1311](https://github.com/googleapis/python-bigquery/issues/1311)) ([1de7a52](https://github.com/googleapis/python-bigquery/commit/1de7a52cb85d4876e4aa87346aff5725c8294c4e))
+
+## [3.3.1](https://github.com/googleapis/python-bigquery/compare/v3.3.0...v3.3.1) (2022-08-09)
+
+
+### Bug Fixes
+
+* **deps:** allow pyarrow < 10 ([#1304](https://github.com/googleapis/python-bigquery/issues/1304)) ([13616a9](https://github.com/googleapis/python-bigquery/commit/13616a910ba2e9b7bc3595847229b56e70c99f84))
+
## [3.3.0](https://github.com/googleapis/python-bigquery/compare/v3.2.0...v3.3.0) (2022-07-25)
diff --git a/PKGBUILD b/PKGBUILD
index bed312b3c386..467bf2bea83b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,58 +2,59 @@
# Contributor: Kaizhao Zhang <zhangkaizhao@gmail.com>
pkgname=python-google-cloud-bigquery
+_pkgname="${pkgname#python-}"
_pkg=python-bigquery
-pkgver=3.3.0
+pkgver=3.4.1
pkgrel=1
pkgdesc="Google BigQuery API client library"
arch=('any')
url="https://github.com/googleapis/python-bigquery"
license=('Apache')
depends=(
- 'python-pyarrow'
'python-dateutil'
'python-google-api-core'
- 'python-google-cloud-core'
'python-google-cloud-bigquery-storage'
+ 'python-google-cloud-core'
'python-google-resumable-media'
'python-grpcio'
'python-packaging'
'python-protobuf'
+ 'python-pyarrow'
'python-requests')
makedepends=(
- 'python-setuptools'
+ 'ipython'
'python-build'
'python-installer'
- 'python-wheel'
- 'python-sphinx'
'python-recommonmark'
- 'ipython')
+ 'python-setuptools'
+ 'python-sphinx'
+ 'python-wheel')
optdepends=(
'ipython'
- 'python-pandas: pandas support'
- 'python-tqdm: tqdm support'
'python-fastparquet: fastparquet support'
+ 'python-llvmlite: fastparquet support'
+ 'python-pandas: pandas support'
'python-snappy: fastparquet support'
- 'python-llvmlite: fastparquet support')
+ 'python-tqdm: tqdm support')
changelog=CHANGELOG.md
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('9eb15a14b8b0f9768402ef042d2971466449f0c79313a57769dca5f4c1874635')
+# source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/g/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('884689714d98a2364dde9c7c367e8228c7116108bbad7a6365dfde391638985b')
build() {
- cd "$_pkg-$pkgver"
+ cd "$_pkgname-$pkgver"
python -m build --wheel --no-isolation
# PYTHONPATH="$PWD" sphinx-build -b man docs/ _build
}
package() {
- export PYTHONHASHSEED=0
- cd "$_pkg-$pkgver"
+ cd "$_pkgname-$pkgver"
python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dvm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
# install -Dm644 _build/google-cloud-bigquery.1 -t "$pkgdir/usr/share/man/man1/"
local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
- install -d "$pkgdir/usr/share/licenses/$pkgname/"
- ln -s \
- "$_site/google_cloud_bigquery-$pkgver.dist-info/LICENSE" \
+ install -dv "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -sv \
+ "$_site/${_pkgname//-/_}-$pkgver.dist-info/LICENSE" \
"$pkgdir/usr/share/licenses/$pkgname/"
}