summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAseem Athale2023-09-22 19:17:54 +0530
committerAseem Athale2023-09-22 19:17:54 +0530
commitedd9cb8ee6129dc721c84aae3a51cf2dcc21839e (patch)
treea9de8bf4604a7eca2323562519ff0ef4d9645df4
parentfb3f5c8a4d7d4780138712b5c5a1c0757e0256a7 (diff)
downloadaur-edd9cb8ee6129dc721c84aae3a51cf2dcc21839e.tar.gz
python-google-cloud-firestore: upgpkg: 2.12.0
Signed-off-by: Aseem Athale <athaleaseem@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cafac0522339..39576522ac6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-google-cloud-firestore
pkgdesc = Google's Firestore Python client library
- pkgver = 1.9.0
+ pkgver = 2.12.0
pkgrel = 1
url = https://github.com/googleapis/python-firestore
arch = x86_64
license = APACHE
makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
- source = https://github.com/googleapis/python-firestore/archive/v1.9.0.tar.gz
- sha256sums = 889ea0f4a8926c796f055627f12db96c4d29632159eff5b7032cfecd23283093
+ source = https://github.com/googleapis/python-firestore/archive/v2.12.0.tar.gz
+ sha256sums = 9f44566b6b29dc45095c53d3fb49ce267aa799726a427ab6a1ff3942873ab092
pkgname = python-google-cloud-firestore
-
diff --git a/PKGBUILD b/PKGBUILD
index 06b079b12ae0..95a868a76368 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,28 @@
-# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+# Maintainer: Aseem Athale <athaleaseem@gmail.com>
+# Contributor: Grey Christoforo <first name [at] last name [dot] net>
pkgname=python-google-cloud-firestore
-pkgver=1.9.0
+pkgver=2.12.0
pkgrel=1
pkgdesc="Google's Firestore Python client library"
arch=(x86_64)
url=https://github.com/googleapis/python-firestore
license=(APACHE)
depends=('python')
-makedepends=(python-setuptools)
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
source=(https://github.com/googleapis/python-firestore/archive/v${pkgver}.tar.gz)
-sha256sums=('889ea0f4a8926c796f055627f12db96c4d29632159eff5b7032cfecd23283093')
-
-prepare() {
- cd "python-firestore-$pkgver"
- #versioneer install
-}
+sha256sums=('9f44566b6b29dc45095c53d3fb49ce267aa799726a427ab6a1ff3942873ab092')
build() {
cd "python-firestore-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "python-firestore-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim:ts=2:sw=2:et: