summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-11-11 09:04:01 +1100
committerPumpkinCheshire2020-11-11 09:04:01 +1100
commit3f05a450e930815beec30d819262e2237b38e957 (patch)
tree777062c84a6a36a7b2c84ce3f09ea0f3f767b8d0
downloadaur-3f05a450e930815beec30d819262e2237b38e957.tar.gz
rename python-speech
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD33
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..505e50ec2dd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-google-cloud-speech
+ pkgdesc = A google cloud speech api for python to convert audio to text.
+ pkgver = 2.0.0
+ pkgrel = 2
+ url = https://github.com/googleapis/python-speech
+ arch = any
+ license = Apache
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python-libcst
+ depends = python-proto-plus
+ depends = python-google-api-core
+ source = https://files.pythonhosted.org/packages/source/g/google-cloud-speech/google-cloud-speech-2.0.0.tar.gz
+ sha256sums = 523d9cefd12c03c14a8bb6ba6fcc945fff8ec554662a518e3039fffcaaa6fc61
+
+pkgname = python-google-cloud-speech
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..78b3a645e298
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+*.log
+*.rpm
+*.deb
+*.tar*
+*.gz
+*.zip
+*.run
+*.whl
+*.AppImage
+*.jar
+*.tgz
+*.pdf
+
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..718271ce9482
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: PumpkinCheshire <sollyonzou@gmail.com>
+
+pkgname=python-google-cloud-speech
+_name=google-cloud-speech
+pkgver=2.0.0
+pkgrel=2
+pkgdesc="A google cloud speech api for python to convert audio to text."
+arch=('any')
+url="https://github.com/googleapis/python-speech"
+license=('Apache')
+depends=('python-libcst'
+ 'python-proto-plus'
+ 'python-google-api-core')
+makedepends=('python'
+ 'python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('523d9cefd12c03c14a8bb6ba6fcc945fff8ec554662a518e3039fffcaaa6fc61')
+
+prepare() {
+ mv -v "${_name}-${pkgver}" "${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}