summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2021-03-04 11:43:04 +0800
committerPumpkinCheshire2021-03-04 11:43:04 +0800
commita9b17689e81b7d7bbac67f664272bd30c40dd69c (patch)
treebba92a219f566d93c7e313724e029b50295cf10c
parent8f4c3036d05b1c1e6545339bda811d639db4854b (diff)
downloadaur-a9b17689e81b7d7bbac67f664272bd30c40dd69c.tar.gz
bump to 2.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a693aecc7c7..61234ead9020 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-google-cloud-speech
pkgdesc = A google cloud speech api for python to convert audio to text.
- pkgver = 2.0.1
- pkgrel = 2
+ pkgver = 2.1.0
+ pkgrel = 1
url = https://github.com/googleapis/python-speech
arch = any
license = Apache
@@ -10,8 +10,8 @@ pkgbase = python-google-cloud-speech
depends = python-libcst
depends = python-proto-plus
depends = python-google-api-core
- source = https://files.pythonhosted.org/packages/source/g/google-cloud-speech/google-cloud-speech-2.0.1.tar.gz
- sha256sums = a7428190f4c10440148a273eb4c91480470b34180eec422b7325acdc0b2c0832
+ source = https://files.pythonhosted.org/packages/source/g/google-cloud-speech/google-cloud-speech-2.1.0.tar.gz
+ sha256sums = 4a77a79e990004af96e789565b174f9b971f00afa23142f6673722dae0910b0c
pkgname = python-google-cloud-speech
diff --git a/PKGBUILD b/PKGBUILD
index 52ead2a00a8e..6f7f5fa8ea33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=python-google-cloud-speech
_name=google-cloud-speech
-pkgver=2.0.1
-pkgrel=2
+pkgver=2.1.0
+pkgrel=1
pkgdesc="A google cloud speech api for python to convert audio to text."
arch=('any')
url="https://github.com/googleapis/python-speech"
@@ -14,20 +14,15 @@ depends=('python-libcst'
makedepends=('python'
'python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('a7428190f4c10440148a273eb4c91480470b34180eec422b7325acdc0b2c0832')
-
-prepare() {
- mv -v "${_name}-${pkgver}" "${pkgname}-${pkgver}"
- cd "${pkgname}-${pkgver}"
-}
+sha256sums=('4a77a79e990004af96e789565b174f9b971f00afa23142f6673722dae0910b0c')
build() {
- cd "$pkgname-$pkgver"
+ cd "$_name-$pkgver"
python setup.py build
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$_name-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}