summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrody2024-12-24 10:05:50 +0100
committerBrody2024-12-24 10:05:50 +0100
commitf8877f9abdbd0de65a95148a2c3ad0f161a30712 (patch)
treefb534677feea8d0792c4b5ed57ceb56a18be700e
parentbd38b8095ebaed6f727c301c27dacb19d3bfc8eb (diff)
downloadaur-f8877f9abdbd0de65a95148a2c3ad0f161a30712.tar.gz
Update to 2.19.0
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG.md16
-rw-r--r--PKGBUILD6
3 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 844313c26263..04efaa8929c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = python-google-cloud-storage
pkgdesc = Google Cloud Storage API client library
- pkgver = 2.18.2
+ pkgver = 2.19.0
pkgrel = 1
url = https://github.com/googleapis/python-storage
changelog = CHANGELOG.md
arch = any
- license = Apache
+ license = Apache-2.0
makedepends = python-build
makedepends = python-installer
makedepends = python-recommonmark
@@ -18,7 +18,7 @@ pkgbase = python-google-cloud-storage
depends = python-google-resumable-media
depends = python-requests
optdepends = python-protobuf
- source = python-google-cloud-storage-2.18.2.tar.gz::https://github.com/googleapis/python-storage/archive/v2.18.2.tar.gz
- b2sums = fbc33d053326ca7558d22cc9fa821be7fd5223907b778e78c48f80800f30e0dd3ae1f4269a903a665cc07507daac187d04d00165d7bebdb4f42b6740f9d2a788
+ source = python-google-cloud-storage-2.19.0.tar.gz::https://github.com/googleapis/python-storage/archive/v2.19.0.tar.gz
+ b2sums = 8366b4417215eea83f0456a44f6b3dcb03c139d3c67d1f97e4cd77f83fe1e9dd9af1be23e979ba41f43b1fab916fa7fc6d0cf051082fc5ecf0d54e4c4009ac02
pkgname = python-google-cloud-storage
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 06c80ebae54e..9f3883ec3c7d 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -4,6 +4,22 @@
[1]: https://pypi.org/project/google-cloud-storage/#history
+## [2.19.0](https://github.com/googleapis/python-storage/compare/v2.18.2...v2.19.0) (2024-11-21)
+
+
+### Features
+
+* Add integration test for universe domain ([#1346](https://github.com/googleapis/python-storage/issues/1346)) ([02a972d](https://github.com/googleapis/python-storage/commit/02a972d35fae6d05edfb26381f6a71e3b8f59d6d))
+* Add restore_bucket and handling for soft-deleted buckets ([#1365](https://github.com/googleapis/python-storage/issues/1365)) ([ab94efd](https://github.com/googleapis/python-storage/commit/ab94efda83f68c974ec91d6b869b09047501031a))
+* Add support for restore token ([#1369](https://github.com/googleapis/python-storage/issues/1369)) ([06ed15b](https://github.com/googleapis/python-storage/commit/06ed15b33dc884da6dffbef5119e47f0fc4e1285))
+* IAM signBlob retry and universe domain support ([#1380](https://github.com/googleapis/python-storage/issues/1380)) ([abc8061](https://github.com/googleapis/python-storage/commit/abc80615ee00a14bc0e6b095252f6d1eb09c4b45))
+
+
+### Bug Fixes
+
+* Allow signed post policy v4 with service account and token ([#1356](https://github.com/googleapis/python-storage/issues/1356)) ([8ec02c0](https://github.com/googleapis/python-storage/commit/8ec02c0e656a4e6786f256798f4b93b95b50acec))
+* Do not spam the log with checksum related INFO messages when downloading using transfer_manager ([#1357](https://github.com/googleapis/python-storage/issues/1357)) ([42392ef](https://github.com/googleapis/python-storage/commit/42392ef8e38527ce4e50454cdd357425b3f57c87))
+
## [2.18.2](https://github.com/googleapis/python-storage/compare/v2.18.1...v2.18.2) (2024-08-08)
diff --git a/PKGBUILD b/PKGBUILD
index 0460afa29504..6eb7a82144de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
_pkgname=python-storage
pkgname=python-google-cloud-storage
-pkgver=2.18.2
+pkgver=2.19.0
pkgrel=1
pkgdesc='Google Cloud Storage API client library'
arch=(any)
url=https://github.com/googleapis/python-storage
-license=(Apache)
+license=(Apache-2.0)
depends=(
python-google-api-core
python-google-auth
@@ -31,7 +31,7 @@ makedepends=(
#)
changelog=CHANGELOG.md
source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-b2sums=(fbc33d053326ca7558d22cc9fa821be7fd5223907b778e78c48f80800f30e0dd3ae1f4269a903a665cc07507daac187d04d00165d7bebdb4f42b6740f9d2a788)
+b2sums=('8366b4417215eea83f0456a44f6b3dcb03c139d3c67d1f97e4cd77f83fe1e9dd9af1be23e979ba41f43b1fab916fa7fc6d0cf051082fc5ecf0d54e4c4009ac02')
build() {
cd ${_pkgname}-${pkgver}