summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2020-09-24 16:19:35 +0800
committerKaizhao Zhang2020-09-24 16:19:35 +0800
commit4b713f386fd34d1a66e50b0f613435a32e3e7bf8 (patch)
treec1e8913882c3e21aed2e4eacd5443380a33fc777
downloadaur-4b713f386fd34d1a66e50b0f613435a32e3e7bf8.tar.gz
Initial import with version 1.0.0
Google CRC32C is complex to compile at the moment. So only the pure Python implementation is used currently.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD36
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b3a4f9b9098
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-google-crc32c
+ pkgdesc = A python wrapper of the C library 'Google CRC32C'
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://pypi.org/project/google-crc32c/
+ arch = any
+ license = APACHE
+ makedepends = python-setuptools
+ depends = python>=3.5
+ depends = python-cffi>=1.0.0
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/g/google-crc32c/google-crc32c-1.0.0.tar.gz
+ sha256sums = 9439b960b6ecd847557675d130fc3626d762bf535da595c20a6949a705fb3eae
+
+pkgname = python-google-crc32c
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..11762378c066
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+!.gitignore
+!PKGBUILD
+!*.patch
+!*.install
+!*.sysusers
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e56a55bf847
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+
+_name=google-crc32c
+
+pkgname=python-google-crc32c
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A python wrapper of the C library 'Google CRC32C'"
+arch=('any')
+url="https://pypi.org/project/google-crc32c/"
+license=('APACHE')
+depends=(
+ 'python>=3.5'
+ 'python-cffi>=1.0.0'
+)
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=(
+ "https://files.pythonhosted.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz"
+)
+sha256sums=(
+ '9439b960b6ecd847557675d130fc3626d762bf535da595c20a6949a705fb3eae'
+)
+
+build() {
+ # Google CRC32C is complex to compile at the moment. So only the pure Python implementation is used currently.
+
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}