summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreg Land2022-10-03 22:27:12 -0400
committerGreg Land2022-10-03 22:27:12 -0400
commitd5a80ce33b30cfdc0d7bf06221f3d8922e99f007 (patch)
treedd8407305fbce15349050cc4a6a5205c4d2e5cff
downloadaur-d5a80ce33b30cfdc0d7bf06221f3d8922e99f007.tar.gz
first version
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD36
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a284776df559
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-google-earthengine-api
+ pkgdesc = Python client libraries for calling the Google Earth Engine API.
+ pkgver = 0.1.326
+ pkgrel = 1
+ url = https://github.com/google/earthengine-api
+ arch = any
+ license = APACHE
+ checkdepends = python-pytest
+ checkdepends = python-pytest-mock
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python-google-api-python-client
+ depends = python-google-auth
+ depends = python-google-auth-httplib2
+ depends = python-httplib2
+ depends = python-six
+ optdepends = python-tensorflow
+ source = google-earthengine-api-0.1.326.tar.gz::https://github.com/google/earthengine-api/archive/refs/tags/v0.1.326.tar.gz
+ sha512sums = 222135ea9b73d30a42bd1c2963fb6a60e5c7633cbb50c3cbc9eb5b80dce1ab9bb22fd7e7dda7590604a16aa362cd3ceb6b1c6936fece87b669621f7a455ad4cd
+
+pkgname = python-google-earthengine-api
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c247470e22d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Gregory Land <landjgregory at gmail dot com>
+pkgname=python-google-earthengine-api
+_name=${pkgname#python-}
+pkgver=0.1.326
+pkgrel=1
+pkgdesc="Python client libraries for calling the Google Earth Engine API."
+arch=('any')
+url="https://github.com/google/earthengine-api"
+license=('APACHE')
+depends=(
+ 'python-google-api-python-client'
+ 'python-google-auth'
+ 'python-google-auth-httplib2'
+ 'python-httplib2'
+ 'python-six'
+ )
+makedepends=('python-build' 'python-installer' 'python-wheel')
+optdepends=('python-tensorflow')
+checkdepends=('python-pytest' 'python-pytest-mock')
+source=("$_name-$pkgver.tar.gz::https://github.com/google/earthengine-api/archive/refs/tags/v$pkgver.tar.gz")
+sha512sums=('222135ea9b73d30a42bd1c2963fb6a60e5c7633cbb50c3cbc9eb5b80dce1ab9bb22fd7e7dda7590604a16aa362cd3ceb6b1c6936fece87b669621f7a455ad4cd')
+
+build() {
+ cd "earthengine-api-$pkgver/python"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "earthengine-api-$pkgver/python"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}
+
+#check(){
+# cd "earthengine-api-$pkgver/python/"
+# python -m pytest ee/tests
+#}