summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-23 14:03:13 +0300
committerDimitris Kiziridis2020-07-23 14:03:13 +0300
commit8a6b58fd9196c3da7520526ff9b893fc17f1bbf9 (patch)
treeb27f4fd78379ddbe68f949269c23f1390d84a4c3
downloadaur-8a6b58fd9196c3da7520526ff9b893fc17f1bbf9.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32da8b6631e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-google-pasta
+ pkgdesc = Library to refactor python code through AST manipulation
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/google/pasta
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python-six
+ source = python-google-pasta-0.2.0.tar.gz::https://github.com/google/pasta/archive/v0.2.0.tar.gz
+ sha256sums = b9e3bcf5ab79986e245c8a2f3a872d14c610ce66904c4f16818342ce81cf97d2
+
+pkgname = python-google-pasta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15a18f859e38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=python-google-pasta
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='Library to refactor python code through AST manipulation'
+arch=('any')
+url='https://github.com/google/pasta'
+license=('Apache')
+depends=('python-six')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/google/pasta/archive/v${pkgver}.tar.gz")
+sha256sums=('b9e3bcf5ab79986e245c8a2f3a872d14c610ce66904c4f16818342ce81cf97d2')
+
+package() {
+ cd "pasta-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+} \ No newline at end of file