summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamLukeYes2021-09-08 11:32:13 +0800
committerSamLukeYes2021-09-08 11:32:13 +0800
commit64b73099685f41c973844b73ebe84d75e76840e2 (patch)
treef30b4418352808e9d75f9c0e63d9cff9dcc265db
parent073e675007dbe6ba711c86a85a29ac1f943e451b (diff)
downloadaur-64b73099685f41c973844b73ebe84d75e76840e2.tar.gz
fix httpx version
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD18
3 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 618928f64666..8bb2867a2318 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-googletrans-git
pkgdesc = Free Google Translate API for Python. Git version.
- pkgver = 3.0.0
+ pkgver = r116.d15c94f
pkgrel = 1
url = https://github.com/ssut/py-googletrans
arch = any
license = MIT
- depends = python-setuptools
+ makedepends = python-setuptools
+ makedepends = git
depends = python-httpx
+ provides = python-googletrans
+ conflicts = python-googletrans
source = git+https://github.com/ssut/py-googletrans.git
sha512sums = SKIP
pkgname = python-googletrans-git
-
diff --git a/.gitignore b/.gitignore
index 42e1348a349b..d4f59fb826ed 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,5 @@
-*.tar.gz
src/
pkg/
-*.tar.xz
-*.tar.zst
-py-googletrans
+py-googletrans/
+*.log
+*.tar* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index b61df3c49e00..1eb6bce442ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,35 @@
-# Maintainer: Mufeed Ali <fushinari@protonmail.com>
+# Maintainer: Sam L. Yes <samlukeyes123 at gmail dot com>
+# Contributor: Mufeed Ali <fushinari@protonmail.com>
pkgname=python-googletrans-git
_author=ssut
_gitname=py-googletrans
-pkgver=0.r115.4f7c079
+pkgver=r116.d15c94f
pkgrel=1
pkgdesc="Free Google Translate API for Python. Git version."
arch=('any')
license=('MIT')
url="https://github.com/ssut/py-googletrans"
depends=(
- python-setuptools
python-httpx
)
+makedepends=(
+ python-setuptools
+ git
+)
provides=('python-googletrans')
conflicts=('python-googletrans')
source=("git+https://github.com/$_author/$_gitname.git")
sha512sums=('SKIP')
+prepare() {
+ cd ${srcdir}/$_gitname
+ sed -i 's|httpx==|httpx>=|' setup.py
+}
+
pkgver() {
cd "$_gitname"
- printf '0.r%s.%s' \
+ printf 'r%s.%s' \
"$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
@@ -32,5 +41,6 @@ build() {
package() {
cd "$_gitname"
python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}