summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharlie Wolf2017-01-14 23:22:01 -0600
committerCharlie Wolf2017-01-14 23:23:27 -0600
commit86d9321495a6b50704b0737ed3935f8344a4ac12 (patch)
treede097751f6e88787ffd2263acd6ecde38d18e105
downloadaur-86d9321495a6b50704b0737ed3935f8344a4ac12.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b623984e0f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-gpgauth
+ pkgdesc = This module allows easy access to gpgauth's key management, encryption and signature functionality from Python programs.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/charliewolf/python-gpgauth
+ arch = any
+ license = Tequilaware
+ makedepends = python-setuptools
+ depends = python
+ depends = python-gnupg
+ source = https://github.com/charliewolf/python-gpgauth/archive/0.1.tar.gz
+ sha256sums = 966fd9ddce241288877028a51b8de14cb202585f16e86a0807036e89ac162c84
+
+pkgname = python-gpgauth
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ed69dd4768c8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+pkg
+src
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..824a093a21ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Charlie Wolf <charlie@wolf.is>
+# Contributor: Charlie Wolf <charlie@wolf.is>
+
+pkgname=python-gpgauth
+pkgver=0.1
+pkgrel=1
+pkgdesc="This module allows easy access to gpgauth's key management, encryption and signature functionality from Python programs."
+url="https://github.com/charliewolf/python-gpgauth"
+license=("Tequilaware")
+arch=("any")
+depends=('python' 'python-gnupg')
+makedepends=('python-setuptools')
+source=("https://github.com/charliewolf/python-gpgauth/archive/${pkgver}.tar.gz")
+sha256sums=('966fd9ddce241288877028a51b8de14cb202585f16e86a0807036e89ac162c84')
+
+build() {
+ cd $srcdir/${pkgname}-${pkgver}/
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/${pkgname}-${pkgver}/
+ python setup.py install --root=${pkgdir}/ --optimize=1
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+