summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Saric2022-11-15 01:08:28 +0100
committerIgor Saric2022-11-15 01:08:28 +0100
commit2e531921f98ae4e424cc57e8fa5abf65352f9f50 (patch)
tree3f7b61ff14e36a03f90f814f007de24d153d259a
parent10fc09b9944e9249b6ab924ddddf61d66037abb4 (diff)
downloadaur-2e531921f98ae4e424cc57e8fa5abf65352f9f50.tar.gz
fix dependency
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f9b31943bb6..623f2722279d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-gpiozero
pkgdesc = A simple interface to GPIO devices with Raspberry Pi
pkgver = 1.6.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/gpiozero/gpiozero
arch = any
license = BSD
depends = python-colorzero
depends = python-setuptools
optdepends = python-spidev: for SPI access
- optdepends = python-raspberry-gpio: for pin access via raspberry-gpio-python library
+ optdepends = python-rpi-gpio: for pin access via raspberry-gpio-python library
source = gpiozero-1.6.2.tar.gz::https://github.com/gpiozero/gpiozero/archive/v1.6.2.tar.gz
sha256sums = 7e6da923774437e24edc0c056e486415bace8c4ba4123c22ac4214147854ea6d
diff --git a/PKGBUILD b/PKGBUILD
index ccaaa686c5a1..95a0d889c06f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
-# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Maintainer: Igor Saric <karabaja4 -at- gmail -dot- com>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
# Contributor: Giampaolo Mancini <giampaolo@trampolineup.com>
_pkgname=gpiozero
pkgname="python-${_pkgname}"
pkgver=1.6.2
-pkgrel=1
+pkgrel=2
pkgdesc='A simple interface to GPIO devices with Raspberry Pi'
arch=('any')
url="https://github.com/${_pkgname}/${_pkgname}"
license=('BSD')
optdepends=(
'python-spidev: for SPI access'
- 'python-raspberry-gpio: for pin access via raspberry-gpio-python library'
+ 'python-rpi-gpio: for pin access via raspberry-gpio-python library'
)
depends=('python-colorzero' 'python-setuptools')
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/${_pkgname}/${_pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('7e6da923774437e24edc0c056e486415bace8c4ba4123c22ac4214147854ea6d')
-
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py build
@@ -28,5 +28,3 @@ package() {
python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
install -Dm644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-
-# vim:set ts=2 sw=2 et: